1

I've been trying to get into Ubuntu for sometime. I really want to get off Windows, as I love a lot of aspects with Linux.

EDIT/UPDATE: This is the URL created by boot repair: the following URL: http://paste.ubuntu.com/p/SBFWycCyQq/

Problem; (sorry if this has been covered but I've tried a lot of solutions online and cant get a fix.)

I fresh installed win 10 with UEFI (secure boot & Fast boot disabled). updated.

I created three partitions /,home & swap. On a GPT partition. Then installed Ubuntu 18.xx (UEFI) BUT... where I think I went wrong was on the installation screen I selected "windows boot manager" then clicked install.

Was I supposed to install to /dev/sda?

I can boot into Ubuntu from F9. But otherwise boot straight into Windows.

I've tried;

WINDOWS CMD (admin): bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

My BIOS has no boot options for OS order just: windows boot manager.

Within Ubuntu:

add-apt-repository ppa:yannubuntu/boot-repair

apt update

I guess I need GRUB (2) to be the boot manager. But not sure how to make this happen or will I still be able to boot into Windows ( I will get away from it eventually but still need MS at this point).

Is the following a good option?

manually add windows entry: This solution provides a proper entry in the grub2 menu to boot into Windows 10. First check on which disk and partition is the Windows EFI boot

fdisk -l

Now found the UUID of the partition

blkid /dev/sda2

/dev/sda2: UUID="1AC3-9984" TYPE="vfat" PARTLABEL="EFI system partition" PARTUUID="dda518e7-aa6d-4944-9a59-e459f0f7944e" Then you can edit the /etc/grub.d/40_custom grub file to add the lines which will help you to boot into your Windows system

vim /etc/grub.d/40_custom

menuentry 'Windows 10 (on /dev/sda2)' --class windows --class os $menuentry_id_option 'osprober-efi-1AC$ insmod part_gpt insmod ntfs insmod search_fs_uuid insmod chain

    set root='hd0,gpt2'
    if [ x$feature_platform_search_hint = xy ]; then
      search --no-floppy --fs-uuid --set=root --hint-bios=hd0,gpt2 --hint-efi=hd0,gpt2 --hint-barem$
    else
      search --no-floppy --fs-uuid --set=root 1AC3-9984
    fi
    chainloader /EFI/Microsoft/Boot/bootmgfw.efi

} note that entry is configured to boot from the 2nd partition gpt2 of the 1st hard drive hd0 or ahci0. If you are working on legacy, then replace all gpt with msdos Now you can update the grub file

upgrade-grub

apt install -y boot-repair && boot-repair

I really appreciate any help provided.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.