2

My printer is Canon Pixma MX922. Its on my home wifi, and other Macbook computers on the network can access it. However, I can't print to it from my new Ubuntu 18.04 computer.

  1. The printer is automatically detected by the OS, but it shows "Does not accept jobs" as show below.

enter image description here

  1. I can select it as a target printer in Chrome and print to it, but nothing happens. Not even an error message.

  2. I tried removing the printer, but it gets added automatically by the OS.

  3. On the CUPS printer list page ( http://localhost:631/printers/ ) the printer is not listed. And when I choose the "Find new printers" option under the Administration page, it says that no printers are found. It's odd that the CUPS localhost page doesn't see the printer but the Ubuntu printers settings does.

  4. The error log, accessible in the localhost CUPS page, shows this: E [07/Jul/2018:01:37:15 -0700] [CGI] Unable to create PPD file: Printer does not support required IPP attributes or document formats. E [07/Jul/2018:01:37:15 -0700] copy_model: empty PPD file E [07/Jul/2018:01:37:15 -0700] [Client 261] Returning IPP server-error-internal-error for CUPS-Add-Modify-Printer (ipp://localhost/printers/Canon-MX920-series) from localhost

  5. Driverless results: $ driverless ipp://91825D000000.local:631/ipp/print

Any tips? Or anything else I can try?

  • Edit the results of driverless into the question please. – Rinzwind Jul 7 '18 at 9:26
  • @Rinzwind done! – Waleed Abdulla Jul 8 '18 at 2:02
8

I was having the same issue after upgrading to 18.04 and was finally able to resolve it. It seems to be related to an error between adding a printer directly through CUPS vs. using the add printer device option. I also noticed the CUPS errors when attempting to add the printer generically through settings, and after researching CUPS errors here is what I did that resolved the issue:

1) Removed the printer through the interface

2) Shut down the printer completely and re-connected it to the WIFI network.

3) Added the printer back selecting the driverless option through the Add Printer interface

(Note: steps 1-3 may not be completely necessary, but I did them anyway in the interest documenting a path to resolution)

4) From there, I accessed CUPS through: http://localhost:631/admin

(Note: after logging in I noticed the same thing that you did - that the printer wasn't listed at all)

5) From here I proceeded to Add a new printer directly through the CUPS admin page

The printer showed up (Cannon MX922) and I selected to add it using the Default settings.

After that, the printer then showed up through the Device settings (as well as in CUPS), and I also noticed that it not only shows as Ready, but I also have the ink levels showing as well. I then successfully printed a test page and things appear to be working normally (I tried to upload a screen shot for the link below as verification).

Screenshot from Printer listings

From here, I intend to add printers directly through the CUPS admin page vs. the Device settings, as this seems to be the root of the issue.

Hope this helps.

  • 1
    when I try clicking on Add Printer, I get the following error 'Enter your username and password or the root username and password to access this page. If you are using Kerberos authentication, make sure you have a valid Kerberos ticket.' but with no way of entering those values (and not sure what they would be anyways....) – user1015214 Feb 21 at 14:09
  • I entered my ubuntu username and pwd at this point, and it worked – bph May 31 at 10:57
2

Driverless comes from Airprint support; that was introduced into Ubuntu 17.04 and this MX922 is listed as supported;

What about installing the drivers that Canon offer? ..to do that go here http://support-asia.canon-asia.com/contents/ASIA/EN/0100517002.html and click to download and SAVE what will be cnijfilter-mx920series-3.90-1-deb.tar.gz

Open a terminal; copy each command below 1 by 1; paste into the terminal and hit the ENTER key; move on to the next command

cd Downloads

tar -zxvf cnijfilter-mx920series-3.90-1-deb.tar.gz

cd cnijfilter-mx920series-3.90-1-deb

sudo ./install.sh

that last command runs the install script; watch as it will ask you questions; it should set up a new icon in your PRINTERS folder; if you right-click on it, it should say in the MAKE & MODEL line that is uses

cnijfilter-mx920series-3.90-1

so you can see which is which: if the new one works, and the old doesn't maybe delete the old; but Ubuntu may attempt another driverless install; you might have to live with that

  • Hmm... Ubuntu shows it supports the printer, implying that no external driver is needed. And Canon's support page explicitly states that no driver is needed for Ubuntu. I'm wondering why neither Canon nor Ubuntu point me to download this driver. Also, the page says that this was last updated in 2013. I'm hesitant to try it. – Waleed Abdulla Jul 11 '18 at 6:07
  • 1
    the printer came out in 2013; with its driver; neither has changed since then; it is up to you; gutenprint drivers (open-source) are another set of drivers; turboprint turboprint.info is yet another driver system to drive printers ........... – pdc Jul 11 '18 at 9:41
0

I've managed my mx492 to work (as of wonder, scanner part of it worked with no issues!) on 18.04 through CUPS by adding it as CUPS+Gutenprint v5.2.13 (color).

Other options didn't work.

protected by Community Nov 10 '18 at 6:28

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.