0

Trying to install and run Cisco packettracer 7.

thufir@dur:~$ 
thufir@dur:~$ /opt/pt/bin/./PacketTracer7 
/opt/pt/bin/./PacketTracer7: error while loading shared libraries: libQt5ScriptTools.so.5: cannot open shared object file: No such file or directory
thufir@dur:~$ 
thufir@dur:~$ LD_LIBRARY_PATH=/opt/pt/lib /opt/pt/bin/./PacketTracer7
/opt/pt/bin/./PacketTracer7: error while loading shared libraries: libpng12.so.0: cannot open shared object file: No such file or directory
thufir@dur:~$ 
thufir@dur:~$ locate libpng12.so.0
/snap/core/4650/lib/x86_64-linux-gnu/libpng12.so.0
/snap/core/4650/lib/x86_64-linux-gnu/libpng12.so.0.54.0
/snap/core/4650/usr/lib/x86_64-linux-gnu/libpng12.so.0
/snap/core/4830/lib/x86_64-linux-gnu/libpng12.so.0
/snap/core/4830/lib/x86_64-linux-gnu/libpng12.so.0.54.0
/snap/core/4830/usr/lib/x86_64-linux-gnu/libpng12.so.0
/snap/core/4917/lib/x86_64-linux-gnu/libpng12.so.0
/snap/core/4917/lib/x86_64-linux-gnu/libpng12.so.0.54.0
/snap/core/4917/usr/lib/x86_64-linux-gnu/libpng12.so.0
/snap/gnome-3-26-1604/59/lib/x86_64-linux-gnu/libpng12.so.0
/snap/gnome-3-26-1604/59/lib/x86_64-linux-gnu/libpng12.so.0.54.0
/snap/gnome-3-26-1604/59/usr/lib/x86_64-linux-gnu/libpng12.so.0
/snap/gnome-3-26-1604/64/lib/x86_64-linux-gnu/libpng12.so.0
/snap/gnome-3-26-1604/64/lib/x86_64-linux-gnu/libpng12.so.0.54.0
/snap/gnome-3-26-1604/64/usr/lib/x86_64-linux-gnu/libpng12.so.0
/snap/vuze-vs/3/lib/x86_64-linux-gnu/libpng12.so.0
/snap/vuze-vs/3/lib/x86_64-linux-gnu/libpng12.so.0.54.0
/snap/vuze-vs/3/usr/lib/x86_64-linux-gnu/libpng12.so.0
thufir@dur:~$ 

Apparently, because:

It appears the correct library is installed, but CPT requires an older version – 52 instead of 55. A Debian package containing the older version of libicui18n is available at http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.8_amd64.deb.

manually install an old package:

thufir@dur:~/deb$ 
thufir@dur:~/deb$ wget http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.8_amd64.deb
--2018-07-07 04:30:57--  http://security.ubuntu.com/ubuntu/pool/main/i/icu/libicu52_52.1-3ubuntu0.8_amd64.deb
Resolving security.ubuntu.com (security.ubuntu.com)... 91.189.91.26, 91.189.91.23, 91.189.88.152, ...
Connecting to security.ubuntu.com (security.ubuntu.com)|91.189.91.26|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6751362 (6.4M) [application/x-debian-package]
Saving to: ‘libicu52_52.1-3ubuntu0.8_amd64.deb’

libicu52_52.1-3ubuntu0.8_amd64.de 100%[==========================================================>]   6.44M   658KB/s    in 10s     

2018-07-07 04:31:07 (637 KB/s) - ‘libicu52_52.1-3ubuntu0.8_amd64.deb’ saved [6751362/6751362]

thufir@dur:~/deb$ 
thufir@dur:~/deb$ sudo dpkg -i libicu52_52.1-3ubuntu0.8_amd64.deb
[sudo] password for thufir: 
Selecting previously unselected package libicu52:amd64.
(Reading database ... 186168 files and directories currently installed.)
Preparing to unpack libicu52_52.1-3ubuntu0.8_amd64.deb ...
Unpacking libicu52:amd64 (52.1-3ubuntu0.8) ...
Setting up libicu52:amd64 (52.1-3ubuntu0.8) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
thufir@dur:~/deb$ 
thufir@dur:~/deb$ packettracer
Starting Packet Tracer 7.1.1
thufir@dur:~/deb$ 

Same result. Installed packages include:

sudo apt install libqt5webkit5 libqt5multimedia5 libqt5xml5 libqt5script5 libqt5scripttools5
3
  • 1
    You should contact Cisco for detailed instructions how to install CPT on 18.04 LTS.
    – N0rbert
    Commented Jul 7, 2018 at 10:52
  • 1
    You are missing a different library (libpng12.so.0) than in the linked instructions (libicui18n.so.52), so installing libicui18n.so.52 won't help you. Also, the locate results for libpng12.so.0 are from snaps, which are self-contained and not shared. You can try installing libpng12.so.0 from here, which is apparently for xenial but may work on bionic.
    – danzel
    Commented Jul 7, 2018 at 12:03
  • right you are, @danzel -- pardon, tired.
    – Thufir
    Commented Jul 7, 2018 at 13:34

2 Answers 2

3

Download the libpng12 package from here, then install it with your package manager, or with sudo dpkg -i <package>

I only had to install this package for it to work.

0

these packages seem to have fixed the problem:

thufir@dur:~/deb$ 
thufir@dur:~/deb$ sudo dpkg -i libicu52_52.1-3ubuntu0.8_amd64.deb libpng12-0_1.2.54-1ubuntu1_amd64.deb 
(Reading database ... 186208 files and directories currently installed.)
Preparing to unpack libicu52_52.1-3ubuntu0.8_amd64.deb ...
Unpacking libicu52:amd64 (52.1-3ubuntu0.8) over (52.1-3ubuntu0.8) ...
Preparing to unpack libpng12-0_1.2.54-1ubuntu1_amd64.deb ...
Unpacking libpng12-0:amd64 (1.2.54-1ubuntu1) over (1.2.54-1ubuntu1) ...
Setting up libicu52:amd64 (52.1-3ubuntu0.8) ...
Setting up libpng12-0:amd64 (1.2.54-1ubuntu1) ...
Processing triggers for libc-bin (2.27-3ubuntu1) ...
thufir@dur:~/deb$ 

althought I'm not precisely sure that was all that was needed, I installed other packages as well.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .