2

I've been having an issue lately with Minecraft on my Ubuntu 18.04 machine. When I try to login to a server, I get a message saying the auth servers are down. However, I can confirm from Mojang's website and from friends that can connect to server that they are not down and the error is client side.

I've tried all the following solutions, but none have worked thus far:

sudo /var/lib/dpkg/info/ca-certificates-java.postinst configure
sudo apt-get install ca-certificates-java
sudo dpkg --purge --force-depends ca-certificates-java
sudo apt-get install --reinstall ca-certificates-java
sudo update-ca-certificates -f
1

I had a similar issues.

The problem with all the fixes i found was that i installed Minecraft via snap. sudo snap install minecraft and because snaps are self contained the java on my machine did not effected it.

What fixed it for me was installing the old launcher instead.

  1. Remove snap version sudo snap remove minecraft
  2. completely remove java 10 ( If Installed )
  3. Install Minecraft Via curl Script
  • 1
    Had the exact same problem here. Snap's version of minecraft has an out-of-date certificate, or is pointing in the wrong direction, or something. Removing the existing openjdk and running your script solved this for me, though I made some tweaks to the script for my system. – hoosierEE Sep 25 '18 at 19:46
0

Fixed!

After extensive research, I found the solution.

Download the tar.gz archive for Java 8 on the Oracle website, go to /etc/ssl/certs/java and delete "cacerts", extract the files from the tar.gz archive, navigate to jre/lib/security and move the cacerts file to /etc/ssl/certs/java.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.