9

I have the lock screen disabled and the screen goes blank after 10 minutes. When I return to my PC and move the mouse, the screen unblanks and I'm presenting with a digital clock display (time and date). I need to press a key to dismiss it (it's not a screen saver or the lock screen, so I don't know what to call it) in order to see my desktop.

Is there any way to disable this? When the screen unblanks, I want to see my desktop, not some other screen.

I'm using Ubuntu 18.04.

  • Possible duplicate of Disable lock screen in 17.10? – Terrance Jul 6 '18 at 18:58
  • I don't think so. I uninstalled gnome-screensaver, and now I can't blank the screen at all. My problem isn't when the screen goes blank, because that works okay. My problem is that when the screen unblanks, I don't get see my desktop. – lord_nimon Jul 6 '18 at 19:02
  • 1
    Ok, one of the answers in that question was to use this: extensions.gnome.org/extension/672/disable-screen-shield. That is what I want, but unfortunately it doesn't work on Ubuntu 18. – lord_nimon Jul 6 '18 at 19:06
  • I removed my close vote. I don't see where to turn off the screen-shield at the moment. Maybe the writer of that extension will update it for Ubuntu 18.04. – Terrance Jul 6 '18 at 19:30
  • 1
    This "feature" is annoying me too. But it should be mentioned that on the digital clock display you can just start typing your password and hit enter to get directly to the desktop (assuming you're the only user or the pre-selected of multiple users). – smcs Feb 21 '19 at 11:47
4
  • Go to "Ubuntu Software" application.
  • Search for "disable screen shield".
  • Install it.

enter image description here

| improve this answer | |
  • This works on Ubuntu 19.10. You need to either reboot/logout or restart gnome. The README in the repository shows how to properly enable it if it doesn't work. Gnome Tweak application is very useful to verify if it's enabled or not. github.com/lgpasquale/… – Emilio M. Apr 9 at 19:24
3

[heavily edited, was wrong about some assumptions]

Ok so the gnome team seem to have eventually realized that the screen shield implementation of GDM 3 is an abomination. (indeed it is absolutely atrocious, without any doubt whatsoever).

And have started working on a replacement. When that is finally ready, they will be able to retire the old screen shield. And any features of it would be re-implemented (presumably from scratch, we would hope). And integrated into the new login screen itself, as a single element.

So no more separate screen shield. Getting in the way, causing a nuisance.

The place to look at this new development work, while it is ongoing, seems to be over here:

https://gitlab.gnome.org/GNOME/gnome-shell/issues/276

[edit 2]

Unfortunately the new design still seems to make the screen shield a mandatory part of the login screen. This is not actually what we wanted. A good place to complain about this would be at the link above ^ (login required). Or on alan's associated blog page / article about the new login screen design / proposal.

Until / unless they change their minds, then I can only recommend people try switching over to a different wayland compatible display manager. Researching the competition other than GDM3, only SDDM currently supports wayland too. Which is the login manager for KDE Plasma. So installing this on a stock version of ubuntu could mess up your installation. Due to all it's other KDE dependencies. Therefore a fresh install of kubuntu from scratch is safer. Try out the Kubuntu Live USB / ISO Disk Image before switching.

[how i reached this conclusion]

A breadcrumbs trail of prior gnome3 bugs leading up to it. Since the gnome3 developers say they are not planning to fix the existing / current / old screen shield included in 18.04 in the meantime...

These bugs are listed in a reverse order, from new to old:

https://bugzilla.gnome.org/show_bug.cgi?id=720656

https://bugzilla.gnome.org/show_bug.cgi?id=696330

https://bugs.launchpad.net/ubuntu/+source/gnome-shell/+bug/1049645

| improve this answer | |
2

I tried this gnome-shell-extension and it works for me:

https://github.com/lgpasquale/gnome-shell-extension-disable-screenshield

| improve this answer | |
  • What version of ubuntu and gnome shell are you using? – Dreamcat4 Aug 13 '18 at 18:58
  • 2
    It's broken on Ubuntu 18: github.com/lgpasquale/… – lord_nimon Aug 13 '18 at 20:38
  • I just tested in Ubuntu 18.04.2 and it works! Remember to disable Automatic Screen Lock in Settings > Privacy. – Diego V Apr 10 '19 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.