2

I'm using Ubuntu 16.04.

My Ubuntu Software doesn't show installed programs or available programs any more. the All tab doesn't show available programs since my last update.

My Software Updater shows 90Mb of updates to be downloaded but the technical description and the details of the updates are invisible I have tried running

sudo apt-get install --reinstall software-center

and

sudo apt-get remove --purge software-center
sudo apt-get install software-center

but there is no change.

When opening Ubuntu Software Center (not Ubuntu Software), it shows Software Center was not removed.

From the terminal while removing software center:

dpkg: warning: while removing software-center,
 directory '/usr/share/software-center/softwarecenter/backend/piston'
 not empty so not removed
dpkg: warning: while removing software-center,
 directory '/usr/share/software-center/softwarecenter/distro'
 not empty so not removed
dpkg: warning: while removing software-center,
 directory '/usr/share/software-center/softwarecenter/db'
 not empty so not removed

Right after removing Software Center with the terminal, the program is still available (Ubuntu Software) and keeps doing the same but now the icon of the Ubuntu Software Center is missing.

  • I've had the same issue since the kernel upgrade last week. The Software Center has always been buggy and has never been fixed properly. I've decided to delete it permanently. You can always see what's installed from xdg-open /usr/share/applications. – Paul Benson Jul 6 '18 at 16:48
  • Please see: askubuntu.com/questions/1051107/… There are bugs filed against the Ubuntu Software not showing applications any more. Removing and reinstalling does not fix it. It is something Canonical has to address, or it could be further upstream with the GNOME Software developers. The original Ubuntu Software does work still, but it is not fully updated. I posted that in my answer. – Terrance Jul 6 '18 at 16:56
  • any advice on the 'software updater', how to reinstal or repair it? – Giulo Figlio Jul 6 '18 at 17:00
  • 1
    sudo apt install --reinstall software-properties-gtk should reinstall the software updater. – Terrance Jul 6 '18 at 17:03
  • 1
    Did you disable the xenial-updates repo by accident? – Terrance Jul 6 '18 at 21:47
1

Since this is a known bug which Canonical must fix, may I offer an alternative until then? https://help.ubuntu.com/stable/ubuntu-help/addremove-install-synaptic.html.en describes the Synaptic Package Manager which is described in the link above as more powerful and can do some software management tasks which Ubuntu Software can't.

1

You can fix some problems with:

pkill gnome-software
sudo rm -r /var/cache/app-info
sudo appstreamcli refresh --force --verbose

These lines solved my problems :-)

Found the above commands in this answer to Why is Ubuntu Software Center dropping previously provided applications? by Terrance.

  • This cleared up my problem with the Software app being out of touch with reality. – Fred Hamilton Dec 10 '18 at 4:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.