0

I have searched google, askubuntu and stackoverflow and I cannot find a solution to my situation.

currently on ubuntu 16.04.4 LTS

previously connected to Netgear R7000 behind att pace 5268AC with a static ip. I have moved and have a new router, in current searches ifconfig is depreciated and recommends ip but nothing covers how to switch/delete /etc/network/interfaces and force ubuntu to only see/use ip configuration (and uncertain that I have configured correctly)

current /etc/network/interfaces

#This files describes the network interfaces available on your system
#and how to activate them. for more intormation, see interfaces(5).

#The loopback network interface

auto lo
iface lo inet loopback

# The primary network interface
auto enp10s0
iface enp10s0 inet static
    address 10.0.0.15
    netmask 255.255.255.0
    gateway 192.168.1.254
    nameservers [8.8.8.8,8.8.4.4]

$ip a

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueque state UNKNKOWN group default qlen 1 link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
     inet 127.0.0.1/8 scope host lo
        valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
        valid_lft forever preferred_lft forever
2: enp10s0:<BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 34:97:f6:a1:2d:6a brd ff:ff:ff:ff:ff

my question is how do I get my router to see my ubuntu NAS again? ideally I would like to delete /etc/network/interfaces and exclusively use ip

edit - takeaways, one I was using r7000 address with Pace gateway; two dns-nameservers had an unnecessary comma

addendum - fixed and can ssh tunnel from LAN, and can access internet from NAS. Pace has R7000 in DMZplus mode, r7000 port forward 10.0.0.15 for ssh tunnel and plex. I can tunnel on same network to 10.0.0.15, ran

curl -s checkip.dyndns.org | sed -e 's/.*Current IP Address: //' -e 's/<.*$//' and got my ip address for my NAS but cannot tunnel via ip address.

2 Answers 2

2

as far as I can deduce from your interfaces file, your router is in a completely different subnet (192.168.1.0) and thus not reachable by your NAS, which is in 10.0.0.0/24. I'm assuming the router also uses a /24 netmask.

Try giving your NAS an IP in the 192.168.1.1-253 range, but make sure you don't assign one that is already in use. Also make sure you are using the same netmask as the router (which I presume will be 255.255.255.0). If you have a PC connected to the router, or access on the router itself, you can use a simple ping to check if the address you want for the NAS is replying or not. If you get a reply, don't use that one.

e.g.:
router at 192.168.1.254
NAS at 192.168.1.15

Removing /etc/network/interfaces on Ubuntu 16.04 is not a good idea. The default network config has been switched to netplan.io in Ubuntu 17.10 and later, if I recall, but not on 16.04.
The ifupdown package (with ifconfig) is still available for those versions, however, but no longer installed by default.

For 16.04, I recommend you keep using the tool you are most comfortable with.

1
  • I just realized that I was using the gateway of the Pace device instead of the netgear. I finally got the netgear r7000 to see my NAS, however I cannot connect to the internet. I can ssh tunnel from the same network
    – el GALLO
    Commented Jul 7, 2018 at 0:37
1

I also have a Pace 5268AC internet appliance; in my case, supplied by AT&T. It’s LAN-side address is also 192.168.1.254.

I also prefer to use my own wireless router behind the Pace. If your Netgear router usually assigns addresses in the 10.0.0.xx range, then the way to set your interfaces file is:

#This files describes the network interfaces available on your system
#and how to activate them. for more intormation, see interfaces(5).

#The loopback network interface

auto lo
iface lo inet loopback

# The primary network interface
auto enp10s0
iface enp10s0 inet static
    address 10.0.0.15
    netmask 255.255.255.0
    gateway 10.0.0.1
    dns-nameservers 8.8.8.8 8.8.4.4

...assuming that 10.0.0.1 is the address of your Netgear router to which all of the devices in your home network are attached. Also, your wording for DNS nameservers was incorrect.

Restart the interface:

sudo ifdown enp10s0 && sudo ifup -v enp10s0

You should be all set.

6
  • I just realized that I was using the gateway of the Pace device instead of the netgear. I finally got the netgear r7000 to see my NAS, however I cannot connect to the internet. I can ssh tunnel from the same network
    – el GALLO
    Commented Jul 7, 2018 at 0:36
  • Can you ping? ping -c3 8.8.8.8 Or else: ping -c3 www.google.com
    – chili555
    Commented Jul 7, 2018 at 15:05
  • I realized my second error, an unnecessary comma dns-nameservers 8.8.8.8, 8.8.4.4 my third error is not setting Pace device into DMZplus for my r7000
    – el GALLO
    Commented Jul 7, 2018 at 19:19
  • So you are all set? Working as expected now?
    – chili555
    Commented Jul 7, 2018 at 19:30
  • mostly, only issue now is i cannot ssh tunnel from external network via NAS public ip address. plex works, and ssh tunnel from LAN, filebot and other scripts can connect to internet, just can't figure out ssh from external network
    – el GALLO
    Commented Jul 7, 2018 at 20:10

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .