0

va"Authentication plugin 'caching_sha2_password' cannot be loaded: /usr/lib/mysql/plugin/caching_sha2_password.so: cannot open shared object file: No such file or directory"

i got this error when i try to connect to mysql from emma or mysql bench on ubuntu 18.04

There is similar issue but it is for windows

https://stackoverflow.com/questions/49963383/authentication-plugin-caching-sha2-password

i tried to reinstall and this

https://stackoverflow.com/a/50027851/9658011

but did not work.

What can i do?

emma

1

Use this query:

ALTER USER 'root'@'localhost' IDENTIFIED WITH mysql_native_password BY 'YourPassword';

You don't get caching_sha2_password.
Then connect to MySQL.

0

I solved. I installed mysql 5.7 on 18.04, not latest version.

738  sudo apt-get purge mysql-server mysql-client mysql-common mysql-server-core- mysql-client-core-
  739  sudo rm -rf /etc/mysql /var/lib/mysql
  740  sudo apt-get autoremove
  741  sudo apt-get autoclean
  742  sudo apt install mysql-client-5.7
  743  sudo apt install mysql-common-5.7
  744  sudo apt install mysql-common
  745  sudo apt install mysql-common-5.7
  746  sudo apt install mysql-client-5.7
  747  systemctl status mysql.service
  748  sudo add-apt-repository 'deb http://archive.ubuntu.com/ubuntu trusty universe'
  749  sudo apt install mysql-client-5.7
  750  sudo apt install mysql-server-5.7
  751  sudo apt install mysql-common-5.8
  752  sudo apt-get purge mysql-client-core-5.6
  753  sudo apt-get autoremove
  754  sudo apt-get autoclean
  755  sudo apt install mysql-client-core-5.5

None of previos worked. So i did those and worked:

  756  sudo apt install mysql-client-core-5.6
  757  sudo apt install mysql-server  
  758  mysql_secure_installation
  759  mysql -u root -p
0

I used

sudo tasksel install lamp-server

mode method, so instead I tend to retain this installation as is, intact.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.