0

I have installed emacs25 from this PPA: https://launchpad.net/~kelleyk/+archive/ubuntu/emacs, and it coexisted well with emacs 24 from the repositories (Ubuntu 16.04). Now that emacs26 is available from the same PPA, I thought I could have all three versions installed. However emacs26 cannot be installed since it shares some files with emacs25, and I cannot remove whatever files were installed with emacs26.

I tried to follow the advice from: Unable to install Emacs 24 from ppa:cassou/emacs, but

sudo apt-get remove `apt-cache search emacs | awk '{print $1}'` --purge 

gives:

~$ sudo apt-get remove `apt-cache search emacs | awk '{print $1}'` --purge
[sudo] password for rafael: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Package 'anthy' is not installed, so not removed
Package 'anthy-common' is not installed, so not removed
Package 'auctex' is not installed, so not removed
Package 'bbdb' is not installed, so not removed
Package 'devhelp' is not installed, so not removed
Package 'emacs' is not installed, so not removed
Package 'emacs-goodies-el' is not installed, so not removed
Package 'exuberant-ctags' is not installed, so not removed
Package 'fetchmail' is not installed, so not removed
Package 'gettext-el' is not installed, so not removed
Package 'libanthy-dev' is not installed, so not removed
Package 'libanthy0' is not installed, so not removed
Package 'tmux' is not installed, so not removed
Package 'acl2-emacs' is not installed, so not removed
Package 'agda' is not installed, so not removed
Package 'agda-bin' is not installed, so not removed
Package 'agda-mode' is not installed, so not removed
Package 'agda-stdlib' is not installed, so not removed
Package 'agda-stdlib-doc' is not installed, so not removed
Package 'alot' is not installed, so not removed
Package 'alot-doc' is not installed, so not removed
Package 'anthy-el' is not installed, so not removed
Package 'anything-el' is not installed, so not removed
Package 'apel' is not installed, so not removed
Package 'aplus-fsf-el' is not installed, so not removed
Package 'ats2-lang' is not installed, so not removed
Package 'auto-complete-el' is not installed, so not removed
Package 'auto-install-el' is not installed, so not removed
Package 'bbdb3' is not installed, so not removed
Package 'bhl' is not installed, so not removed
Package 'bitmap-mule' is not installed, so not removed
Package 'c-sig' is not installed, so not removed
Package 'cafeobj-mode' is not installed, so not removed
Package 'chktex' is not installed, so not removed
Package 'cl-iterate' is not installed, so not removed
Package 'cl-swank' is not installed, so not removed
Package 'clang-format-3.5' is not installed, so not removed
Package 'clang-format-3.6' is not installed, so not removed
Package 'clang-format-3.7' is not installed, so not removed
Package 'cmuscheme48-el' is not installed, so not removed
Package 'colordiff' is not installed, so not removed
Package 'commit-patch' is not installed, so not removed
Package 'common-lisp-controller' is not installed, so not removed
Package 'coq' is not installed, so not removed
Package 'crypt++el' is not installed, so not removed
Package 'cvc3-el' is not installed, so not removed
Package 'cxref-emacs' is not installed, so not removed
Package 'darcsum' is not installed, so not removed
Package 'dash-el' is not installed, so not removed
Package 'ddskk' is not installed, so not removed
Package 'debian-el' is not installed, so not removed
Package 'develock-el' is not installed, so not removed
Package 'devscripts-el' is not installed, so not removed
Package 'dh-elpa' is not installed, so not removed
Package 'dictem' is not installed, so not removed
Package 'dictionary-el' is not installed, so not removed
Package 'dmtcp' is not installed, so not removed
Package 'dmtcp-dbg' is not installed, so not removed
Package 'docbook2x' is not installed, so not removed
Package 'doxymacs' is not installed, so not removed
Package 'dpkg-dev-el' is not installed, so not removed
Package 'e2wm' is not installed, so not removed
Package 'e3' is not installed, so not removed
Package 'eblook' is not installed, so not removed
Package 'ecasound-el' is not installed, so not removed
Package 'ecb' is not installed, so not removed
Package 'edb' is not installed, so not removed
Package 'edict-el' is not installed, so not removed
Package 'eflite' is not installed, so not removed
Package 'egg' is not installed, so not removed
Package 'el-get' is not installed, so not removed
Package 'eldav' is not installed, so not removed
Package 'elpa-aggressive-indent' is not installed, so not removed
Package 'elpa-async' is not installed, so not removed
Package 'elpa-circe' is not installed, so not removed
Package 'elpa-company' is not installed, so not removed
Package 'elpa-editorconfig' is not installed, so not removed
Package 'elpa-epl' is not installed, so not removed
Package 'elpa-expand-region' is not installed, so not removed
Package 'elpa-f' is not installed, so not removed
Package 'elpa-flx' is not installed, so not removed
Package 'elpa-flx-ido' is not installed, so not removed
Package 'elpa-geiser' is not installed, so not removed
Package 'elpa-git-commit' is not installed, so not removed
Package 'elpa-helm' is not installed, so not removed
Package 'elpa-helm-core' is not installed, so not removed
Package 'elpa-js2-mode' is not installed, so not removed
Package 'elpa-magit' is not installed, so not removed
Package 'elpa-magit-popup' is not installed, so not removed
Package 'elpa-markdown-mode' is not installed, so not removed
Package 'elpa-noflet' is not installed, so not removed
Package 'elpa-persp-projectile' is not installed, so not removed
Package 'elpa-perspective' is not installed, so not removed
Package 'elpa-pkg-info' is not installed, so not removed
Package 'elpa-popup' is not installed, so not removed
Package 'elpa-projectile' is not installed, so not removed
Package 'elpa-rust-mode' is not installed, so not removed
Package 'elpa-sml-mode' is not installed, so not removed
Package 'elpa-vala-mode' is not installed, so not removed
Package 'elpa-with-editor' is not installed, so not removed
Package 'elscreen' is not installed, so not removed
Package 'elserv' is not installed, so not removed
Package 'emacs-calfw' is not installed, so not removed
Package 'emacs-calfw-howm' is not installed, so not removed
Package 'emacs-intl-fonts' is not installed, so not removed
Package 'emacs-jabber' is not installed, so not removed
Package 'emacs-nox' is not installed, so not removed
Package 'emacs-window-layout' is not installed, so not removed
Package 'emacspeak' is not installed, so not removed
Package 'emacspeak-espeak-server' is not installed, so not removed
Package 'emacspeak-ss' is not installed, so not removed
Package 'emms' is not installed, so not removed
Package 'erc' is not installed, so not removed
Package 'ess' is not installed, so not removed
Package 'etktab' is not installed, so not removed
Package 'evernote-mode' is not installed, so not removed
Package 'eweouz' is not installed, so not removed
Package 'flim' is not installed, so not removed
Package 'geiser' is not installed, so not removed
Package 'ghc-mod' is not installed, so not removed
Package 'ghc-mod-el' is not installed, so not removed
Package 'global' is not installed, so not removed
Package 'gmult' is not installed, so not removed
Package 'gnat-gps' is not installed, so not removed
Package 'gnats' is not installed, so not removed
Package 'gnats-user' is not installed, so not removed
Package 'gnu-smalltalk-el' is not installed, so not removed
Package 'gnuplot-mode' is not installed, so not removed
Package 'gnuserv' is not installed, so not removed
Package 'goby' is not installed, so not removed
Package 'gocode-auto-complete-el' is not installed, so not removed
Package 'golang-mode' is not installed, so not removed
Package 'gramadoir' is not installed, so not removed
Package 'gri-el' is not installed, so not removed
Package 'haml-elisp' is not installed, so not removed
Package 'haskell-mode' is not installed, so not removed
Package 'howm' is not installed, so not removed
Package 'icicles' is not installed, so not removed
Package 'id-utils' is not installed, so not removed
Package 'idl-font-lock-el' is not installed, so not removed
Package 'ilisp' is not installed, so not removed
Package 'ilisp-doc' is not installed, so not removed
Package 'info2man' is not installed, so not removed
Package 'inform-mode' is not installed, so not removed
Package 'initz' is not installed, so not removed
Package 'inotify-hookable' is not installed, so not removed
Package 'irony-mode' is not installed, so not removed
Package 'ispell' is not installed, so not removed
Package 'jed' is not installed, so not removed
Package 'jedit' is not installed, so not removed
Package 'joe' is not installed, so not removed
Package 'jove' is not installed, so not removed
Package 'js2-mode' is not installed, so not removed
Package 'jupp' is not installed, so not removed
Package 'kdesdk-scripts' is not installed, so not removed
Package 'kxterm' is not installed, so not removed
Package 'latex-cjk-common' is not installed, so not removed
Package 'ledger-el' is not installed, so not removed
Package 'ledit' is not installed, so not removed
Package 'libconfig-find-perl' is not installed, so not removed
Package 'libghc-agda-dev' is not installed, so not removed
Package 'libghc-agda-doc' is not installed, so not removed
Package 'libghc-pandoc-dev' is not installed, so not removed
Package 'libghc-pandoc-doc' is not installed, so not removed
Package 'libghc-pandoc-prof' is not installed, so not removed
Package 'libgnu-regexp-java' is not installed, so not removed
Package 'libkkc-common' is not installed, so not removed
Package 'libkkc-data' is not installed, so not removed
Package 'libkkc-dev' is not installed, so not removed
Package 'libkkc-utils' is not installed, so not removed
Package 'libkkc-utils-dbg' is not installed, so not removed
Package 'libkkc2' is not installed, so not removed
Package 'libkkc2-dbg' is not installed, so not removed
Package 'liblatex-table-perl' is not installed, so not removed
Package 'libledit-ocaml-dev' is not installed, so not removed
Package 'libocp-indent-lib-ocaml' is not installed, so not removed
Package 'libocp-indent-lib-ocaml-dev' is not installed, so not removed
Package 'libparse-exuberantctags-perl' is not installed, so not removed
Package 'libpcre-ocaml' is not installed, so not removed
Package 'libpcre-ocaml-dev' is not installed, so not removed
Package 'libproc-invokeeditor-perl' is not installed, so not removed
Package 'libre-ocaml-dev' is not installed, so not removed
Package 'librep-dev' is not installed, so not removed
Package 'librep16' is not installed, so not removed
Package 'librobert-hooke-clojure' is not installed, so not removed
Package 'libtext-findindent-perl' is not installed, so not removed
Package 'libutop-ocaml' is not installed, so not removed
Package 'libutop-ocaml-dev' is not installed, so not removed
Package 'liece' is not installed, so not removed
Package 'liece-dcc' is not installed, so not removed
Package 'liquidsoap-mode' is not installed, so not removed
Package 'lisaac-mode' is not installed, so not removed
Package 'lookup-el' is not installed, so not removed
Package 'lsdb' is not installed, so not removed
Package 'lua-mode' is not installed, so not removed
Package 'lyskom-elisp-client' is not installed, so not removed
Package 'malaga-mode' is not installed, so not removed
Package 'maxima-emacs' is not installed, so not removed
Package 'mew' is not installed, so not removed
Package 'mew-beta' is not installed, so not removed
Package 'mg' is not installed, so not removed
Package 'mgp' is not installed, so not removed
Package 'mh-e' is not installed, so not removed
Package 'mhc' is not installed, so not removed
Package 'mhc-utils' is not installed, so not removed
Package 'midge' is not installed, so not removed
Package 'migemo-el' is not installed, so not removed
Package 'minlog' is not installed, so not removed
Package 'mit-scheme' is not installed, so not removed
Package 'mit-scheme-dbg' is not installed, so not removed
Package 'mit-scheme-doc' is not installed, so not removed
Package 'mksh' is not installed, so not removed
Package 'mmm-mode' is not installed, so not removed
Package 'mpg123-el' is not installed, so not removed
Package 'mpqc-support' is not installed, so not removed
Package 'mu-cite' is not installed, so not removed
Package 'mu4e' is not installed, so not removed
Package 'muse-el' is not installed, so not removed
Package 'navi2ch' is not installed, so not removed
Package 'nescc' is not installed, so not removed
Package 'nethack-el' is not installed, so not removed
Package 'nethack-lisp' is not installed, so not removed
Package 'ng-cjk' is not installed, so not removed
Package 'ng-cjk-canna' is not installed, so not removed
Package 'ng-common' is not installed, so not removed
Package 'ng-latin' is not installed, so not removed
Package 'nmh' is not installed, so not removed
Package 'nomarch' is not installed, so not removed
Package 'notmuch-addrlookup' is not installed, so not removed
Package 'notmuch-emacs' is not installed, so not removed
Package 'ocaml-core' is not installed, so not removed
Package 'ocaml-mode' is not installed, so not removed
Package 'ocp-indent' is not installed, so not removed
Package 'oneliner-el' is not installed, so not removed
Package 'org-mode' is not installed, so not removed
Package 'otags' is not installed, so not removed
Package 'pandoc' is not installed, so not removed
Package 'pandoc-data' is not installed, so not removed
Package 'paredit-el' is not installed, so not removed
Package 'php-elisp' is not installed, so not removed
Package 'planner-el' is not installed, so not removed
Package 'post-el' is not installed, so not removed
Package 'prolog-el' is not installed, so not removed
Package 'proofgeneral' is not installed, so not removed
Package 'proofgeneral-doc' is not installed, so not removed
Package 'psgml' is not installed, so not removed
Package 'pylint3' is not installed, so not removed
Package 'pymacs' is not installed, so not removed
Package 'pyrex-mode' is not installed, so not removed
Package 'python-editor' is not installed, so not removed
Package 'python-mode' is not installed, so not removed
Package 'python-rope' is not installed, so not removed
Package 'python-ropemacs' is not installed, so not removed
Package 'python-ropemode' is not installed, so not removed
Package 'python3-editor' is not installed, so not removed
Package 'rabbit-mode' is not installed, so not removed
Package 'rail' is not installed, so not removed
Package 'ranger' is not installed, so not removed
Package 'rdtool-elisp' is not installed, so not removed
Package 'refdb-clients' is not installed, so not removed
Package 'refdb-doc' is not installed, so not removed
Package 'refdb-server' is not installed, so not removed
Package 'refdb-www' is not installed, so not removed
Package 'remembrance-agent' is not installed, so not removed
Package 'rep' is not installed, so not removed
Package 'rep-doc' is not installed, so not removed
Package 'riece' is not installed, so not removed
Package 'rnc-mode' is not installed, so not removed
Package 'ruby-github-markup' is not installed, so not removed
Package 'ruby-org' is not installed, so not removed
Package 's-el' is not installed, so not removed
Package 'sass-elisp' is not installed, so not removed
Package 'sawfish' is not installed, so not removed
Package 'scala-mode-el' is not installed, so not removed
Package 'search-ccsb' is not installed, so not removed
Package 'search-citeseer' is not installed, so not removed
Package 'select-xface' is not installed, so not removed
Package 'semi' is not installed, so not removed
Package 'sepia' is not installed, so not removed
Package 'silversearcher-ag-el' is not installed, so not removed
Package 'singular-ui-emacs' is not installed, so not removed
Package 'sisu' is not installed, so not removed
Package 'slime' is not installed, so not removed
Package 'speechd-el' is not installed, so not removed
Package 'speechd-el-doc-cs' is not installed, so not removed
Package 'speechd-up' is not installed, so not removed
Package 'stow' is not installed, so not removed
Package 'stumpwm' is not installed, so not removed
Package 'supercollider-emacs' is not installed, so not removed
Package 'sylpheed' is not installed, so not removed
Package 't-code' is not installed, so not removed
Package 't-code-common' is not installed, so not removed
Package 'tdiary-mode' is not installed, so not removed
Package 'tiarra-conf-el' is not installed, so not removed
Package 'timidity-el' is not installed, so not removed
Package 'tkcon' is not installed, so not removed
Package 'tpp' is not installed, so not removed
Package 'tuareg-mode' is not installed, so not removed
Package 'tweak' is not installed, so not removed
Package 'twittering-mode' is not installed, so not removed
Package 'txt2regex' is not installed, so not removed
Package 'tzc' is not installed, so not removed
Package 'uim-el' is not installed, so not removed
Package 'uim-latin' is not installed, so not removed
Package 'urweb-mode' is not installed, so not removed
Package 'utop' is not installed, so not removed
Package 'uzbl' is not installed, so not removed
Package 'verbiste-el' is not installed, so not removed
Package 'vile' is not installed, so not removed
Package 'vile-common' is not installed, so not removed
Package 'vile-filters' is not installed, so not removed
Package 'vim-voom' is not installed, so not removed
Package 'vm' is not installed, so not removed
Package 'w3m-el' is not installed, so not removed
Package 'w3m-el-snapshot' is not installed, so not removed
Package 'whizzytex' is not installed, so not removed
Package 'windows-el' is not installed, so not removed
Package 'wl' is not installed, so not removed
Package 'wl-beta' is not installed, so not removed
Package 'wordwarvi' is not installed, so not removed
Package 'wordwarvi-sound' is not installed, so not removed
Package 'wysihtml-el' is not installed, so not removed
Package 'x-face-el' is not installed, so not removed
Package 'xcite' is not installed, so not removed
Package 'xcscope-el' is not installed, so not removed
Package 'xemacs21' is not installed, so not removed
Package 'xemacs21-basesupport' is not installed, so not removed
Package 'xemacs21-basesupport-el' is not installed, so not removed
Package 'xemacs21-bin' is not installed, so not removed
Package 'xemacs21-mule' is not installed, so not removed
Package 'xemacs21-mule-canna-wnn' is not installed, so not removed
Package 'xemacs21-mulesupport' is not installed, so not removed
Package 'xemacs21-mulesupport-el' is not installed, so not removed
Package 'xemacs21-nomule' is not installed, so not removed
Package 'xemacs21-support' is not installed, so not removed
Package 'xemacs21-supportel' is not installed, so not removed
Package 'xfonts-bitmap-mule' is not installed, so not removed
Package 'xfonts-kapl' is not installed, so not removed
Package 'xfonts-terminus-oblique' is not installed, so not removed
Package 'xfonts-thai-etl' is not installed, so not removed
Package 'xfonts-thai-poonlap' is not installed, so not removed
Package 'xjed' is not installed, so not removed
Package 'xstow' is not installed, so not removed
Package 'xul-ext-exteditor' is not installed, so not removed
Package 'xvile' is not installed, so not removed
Package 'yaml-mode' is not installed, so not removed
Package 'yasnippet' is not installed, so not removed
Package 'yasnippet-snippets' is not installed, so not removed
Package 'yasr' is not installed, so not removed
Package 'yatex' is not installed, so not removed
Package 'yc-el' is not installed, so not removed
Package 'yorick' is not installed, so not removed
Package 'zeal' is not installed, so not removed
Package 'zeal-dbg' is not installed, so not removed
Package 'zile' is not installed, so not removed
Package 'org-mode-doc' is not installed, so not removed
Package 'sdic' is not installed, so not removed
Package 'wnn7egg' is not installed, so not removed
Package 'x-pgp-sig-el' is not installed, so not removed
Package 'emacs24-dbg' is not installed, so not removed
Package 'emacs24-lucid-dbg' is not installed, so not removed
Package 'emacs24-nox' is not installed, so not removed
Package 'emacs24-nox-dbg' is not installed, so not removed
Package 'erlang-tools' is not installed, so not removed
Package 'clang-format-3.8' is not installed, so not removed
Package 'clang-format-3.9' is not installed, so not removed
Package 'clang-format-4.0' is not installed, so not removed
Package 'clang-format-5.0' is not installed, so not removed
Package 'emacs-mozc' is not installed, so not removed
Package 'emacs-mozc-bin' is not installed, so not removed
Package 'emacs24-lucid' is not installed, so not removed
Package 'erlang' is not installed, so not removed
Package 'erlang-mode' is not installed, so not removed
Package 'git-el' is not installed, so not removed
Package 'idn' is not installed, so not removed
Package 'puppet-el' is not installed, so not removed
Package 'emacs25-nox' is not installed, so not removed
Package 'emacs26-common' is not installed, so not removed
Package 'emacs26-nox' is not installed, so not removed
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 aspell : Depends: dictionaries-common (> 0.40) but it is not going to be installed
 aspell-en : Depends: dictionaries-common (>= 0.49.2) but it is not going to be installed
 aspell-es : Depends: dictionaries-common (>= 1.23~) but it is not going to be installed
 groovy2 : Depends: libjline2-java but it is not going to be installed
 hunspell-en-us : Depends: dictionaries-common (>= 0.10) but it is not going to be installed
 hyphen-en-us : Depends: dictionaries-common (>= 0.10) but it is not going to be installed or
                         openoffice.org-updatedicts
 mythes-en-us : Depends: dictionaries-common but it is not going to be installed
 openoffice.org-hyphenation : Depends: dictionaries-common (>= 0.10) but it is not going to be installed or
                                       openoffice.org-updatedicts
 wbritish : Depends: dictionaries-common (>= 0.20) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
~$ 

and then sudo apt-get -f install gives:

~$ sudo apt-get -f install 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  emacs26-common
The following NEW packages will be installed:
  emacs26-common
0 upgraded, 1 newly installed, 0 to remove and 117 not upgraded.
2 not fully installed or removed.
Need to get 0 B/17.8 MB of archives.
After this operation, 71.9 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 337093 files and directories currently installed.)
Preparing to unpack .../emacs26-common_26.1~1.git07f8f9b-kk1+16.04_all.deb ...
Unpacking emacs26-common (26.1~1.git07f8f9b-kk1+16.04) ...
dpkg: error processing archive /var/cache/apt/archives/emacs26-common_26.1~1.git07f8f9b-kk1+16.04_all.deb (--unpack):
 trying to overwrite '/usr/share/emacs/site-lisp/subdirs.el', which is also in package emacs25-common 25.3~1.gite0284ab-kk1+16.04
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Processing triggers for hicolor-icon-theme (0.15-0ubuntu1) ...
Processing triggers for bamfdaemon (0.5.3~bzr0+16.04.20180209-0ubuntu1) ...
Rebuilding /usr/share/applications/bamf-2.index...
Processing triggers for desktop-file-utils (0.22-1ubuntu5.1) ...
Processing triggers for gnome-menus (3.13.3-6ubuntu3.1) ...
Processing triggers for mime-support (3.59ubuntu1) ...
Processing triggers for man-db (2.7.5-1) ...
Errors were encountered while processing:
 /var/cache/apt/archives/emacs26-common_26.1~1.git07f8f9b-kk1+16.04_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
~$ 

I have also tried sudo apt-get autoremove, with no luck.

How should I proceed? I am not insisting to have both versions 25 and 26 coexisting anymore, I just want a working Ubuntu system with either.

EDIT: I am inserting the results of remove and purge commands.

$ sudo apt remove emacs25
[sudo] password for rafael: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 emacs26 : Depends: emacs26-common but it is not going to be installed
 emacs26-el : Depends: emacs26-common but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
~$ sudo apt remove emacs26
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 emacs26-el : Depends: emacs26-common but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
~$ sudo apt purge emacs25
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 emacs26 : Depends: emacs26-common but it is not going to be installed
 emacs26-el : Depends: emacs26-common but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
~$ sudo apt purge emacs26
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 emacs26-el : Depends: emacs26-common but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
~$ 

After this, the result of sudo apt-get -f install is identical to the shown above.

  • How about sudo apt remove the one you don't want? – fkraiem Jul 6 '18 at 4:42
  • How about sudo apt purge the one you don't want. – waltinator Jul 6 '18 at 4:50
  • @fkraiem @waltinator both commands return the message that emacs26 and emacs26-el have unmet dependencies, and suggest to run apt-get -f install wtih no packages. Running that gives exactly the same as in the original post. – rvf0068 Jul 6 '18 at 13:18
  • purge has nothing to do with unmet dependencies; it only removes config files... Anyway, as usual please provide the full and exact command you ran and output it produced. – fkraiem Jul 6 '18 at 14:37
  • @fkraiem I have edited the question inserting the output of the mentioned commands. – rvf0068 Jul 7 '18 at 3:06
2

Two packages, emacs26 and emacs26-el, have an unmet dependency, emacs26-common. In such cases, Apt suggests running apt-get -f install to install the missing dependency, but installing emacs26-common failed due to a conflict with currently-installed emacs25-common. Thus one must instead first remove emacs26 and emacs26-el (apt remove emacs26 emacs26-el) to put Apt back to a normal state, and then possibly remove emacs25 and all related packages before installing emacs26.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.