0

I have bought a new desktop; it's an Asus VivoBook Pro N552VW. I installed Ubuntu 18.04 in dual boot with Windows 10. The system is working perfectly but it freezes during shutdown/reboot/suspend/hibernate. It also freezes in a singular situation: I succesfully login when I write the correct password on the first try, but if I fail at least one time, then when I write it correctly, it freezes as stated above.

These are PC's detailed:

  • Processor: Intel® Core™ i7 6700HQ Processor
  • OS: Windows 10 Home
  • Chipset: Intel® HM170 Chipset
  • Memory: DDR4 2133 MHz SDRAM, 2 x SO-DIMM socket for expansion up to 16 GB SDRAM
  • Graphics: NVIDIA® GeForce® GTX 960M with 2G/4G GDDR5 VRAM
  • Storage: 2.5" 9.5mm SATA3; 1TB HDD 5400 RPM; 1TB HDD 7200 RPM; PCIE x 4 256G / 512G

.

.

The system is fully updated using Update Manager.

  • How can I determine what is causing the freeze?
  • How can I fix this?

.

.

Initally, Ubuntu didn't power on, but adding acpi=off I could fix it. This rather didn't help me to resolve the shutdown.

I tried these things:

  • I tried adding Intel microcodes, but it didn't help.
  • I added quiet splash in GRUB-edit.
  • I did a lot of changes in GRUB-edit, but nothing brought me a successfully resolution.

After all these attempts, when I powered off my laptop, the typical written that came up was: Wlp2s0: failed to remove key (2, ff:ff:ff:ff:ff:ff) from hardware (-22) and reboot: System halted.

Then, yesterday I added nomodeset in front of quiet splash in GRUB-edit, and Ubuntu stucked no more when the writtens stated above came up, but one step ahead: it stucked at Ubuntu log.

Has somebody ideas? Thank you very much!

  • First thing that comes to mind is, try another distro..... Meant to be more helpful than not. Truly, some distros and versions of the kernel/ GUIS work different on different machines ime – Robert Sederholm Jul 5 '18 at 15:10
  • 1
    I'n actually thinking that, if nobody can give me an answer, I'll try an other distro. Anyway thank you so much for interest!!! – giaco Jul 5 '18 at 23:30
  • I'd try Linux Mint, if I were you. It's basically Ubuntu, but they tweak it to their preferences. If that doesn't work, try an earlier release of Ubuntu or Linux Mint. – Robert Sederholm Jul 6 '18 at 5:39
  • Thank you for your help!!! I'll wait some day for a miracle ahahah, then I'll do it. – giaco Jul 6 '18 at 8:14
  • Stick with Debian or Debian based distros for netflix support! – Robert Sederholm Jul 6 '18 at 18:15
0

This worked for me - https://bugs.launchpad.net/ubuntu/+source/nvidia-graphics-drivers-390/+bug/1756226/comments/20

Using Asus ROG GL752-VW, NVIDIA® GeForce® GTX 960M. Also currently using nvidia-driver-390 instead of Nouveau. Running dual booted Win10 and Ubuntu Mate 18.04.

0

I finally tried an older version: Ubuntu 16.04.4, and it works fine. I think they haven't fixed every bugs with every computers yet.

Thanks to https://askubuntu.com/users/36140/robert-sederholm!

Thanks also to jeydee, who kindly answered me.

0

I had some ACPI related issues on Lenovo IdeaPad 330 running Ubuntu 18.04.1. Passing acpi=off fixed some of them (WLAN card detection, freezes on logout, and most random freezes), but it broke some other things instead: Ubuntu froze on reboots/shutdowns, touchpad didn't work, battery not detected, and also after installing nvidia CUDA drivers nvidia-msi was failing to communicate with /dev/nvidia0 reporting ACPI related errors in dmesg. What worked for me was replacing acpi=off kernel boot option with acpi_osi=Linux (and I also noticed nomodeset the OP mentioned broke some things too). You can read about acpi_osi=Linux option in this answer.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.