10

Why do I get this message on my Lenovo Y720 laptop? I have a thunderbolt 3 port, but for some reason it says this:

enter image description here

I don't suppose it's because I have no cable inserted.

  • Secure boot is disabled
  • Fast boot is disabled
  • AHCI mode enabled
  • UEFI mode enabled
  • The port works if I connect to my phone, but I cannot test it with another thunderbolt device as I do not have any.
4

Not sure if you're still looking for an answer, but I ran into this same issue and got it working.

I'm running Ubuntu Budgie 18.04.1 and it seemed to be missing the bolt package.

If you're also missing the package, running the command

sudo apt install bolt

and then a restart should give you the ability to access your thunderbolt settings.


And no, even with no devices plugged in, you should still be able to see the controls.

Edit: Another thing you can do is run lspci -tv and look to see if the thunderbolt ports are even recognized by the system.

| improve this answer | |
  • 2
    Mine has bolt installed, but it still show No Thunderbolt support. My laptop is XPS 9360. Do you know why? – ismailsunni Aug 6 '18 at 4:32
  • I tried this and it seems it was already installed on the system (preinstalled), so it did not work. – user825380 Aug 7 '18 at 10:58
  • @ismailsunni I have the XPS 9370 (very similar hardware). Do you have all the relevant drivers installed and do you have the most recent BIOS? What Linux kernel are you on? If you're on a dual boot setup, does windows 10 recognize the thunderbolt ports? – Robert Judka Aug 7 '18 at 11:41
  • @mth1417 please look at my edit about viewing the PCIe tree – Robert Judka Aug 7 '18 at 11:49
  • @RobertJudka I use dualboots, I have updated the bios to 2.8.1. What driver should I install for the thunderbolt in ubuntu 18.04? I am using 18.04. I will check on windows later and post it here. – ismailsunni Aug 9 '18 at 8:43
0

Check the BIOS settings for thunderbolt security. I've heard that with the Yoga 720 there is thunderbolt security implemented at the BIOS level. You have to either specifically allow each device or turn the security off.

Also, make sure your thunderbolt 3 device is plugged in when you check this tool. On my Yoga 920, it shows the same thing until a thunderbolt 3 device is actually plugged in, and only then does it "wake up."

Finally, I've found some TB docks don't work as reliably as others. I have a Dell TB16 dock that works somewhat sporadically, but my Lenovo Thunderbolt 3 dock seems to do better (I've only had it for a few days, so jury is still out on stability with Ubunut.)

| improve this answer | |
0

I don't suppose it's because I have no cable inserted.

Actually that is probably exactly the problem. Thunderbolt is controlled by the BIOS and depending on BIOS it can be setup and configured in different ways. What you probably want is BIOS Assisted Mode. That completly disconnects the thunderbolt once the cable is unplugged. You won't see it in lspci or any other tool, and that would explain the screenshot you provided.

| improve this answer | |
0

Thunderbolt controllers in BIOS-assisted enumeration mode go to sleep when not in use. All that is left is a PCI hotplug bridge with no child bridges attached.

The Thunderbolt controllers that break this rule are:

  • Titan Ridge
  • Presumably any future controllers released after Titan Ridge
  • Some Alpine Ridge controllers with updated firmware and BIOS to support (uncommon)

https://www.kernel.org/doc/html/latest/admin-guide/thunderbolt.html

From the above link, we find a command to force the power and wake the controller (usually used for firmware updates without requiring Thunderbolt devices to be attached).

"echo 1 | sudo tee /sys/bus/wmi/devices/86CCFD48-205E-4A77-9C48-2021CBEDE341/force_power" without the quotes, should wake it up. Then "lspci -vnnt" to visualise the difference. If you want, you can post the output of "lspci -vnnt" for us to confirm for you.

But this only works on recent kernels. I cannot remember which one was the first, but 4.20 most definitely has it (and definitely some earlier ones but for the sake of simplicity, just use that one).

Hopefully this works and allows for your Thunderbolt controller to be acknowledged by Ubuntu. However, since you said you do not have any Thunderbolt devices, I am not sure why you care (although I do not say that discouragingly). But that should be the solution.

Oh, and remember, if you have another Thunderbolt 3 laptop and a USB-C to USB-C cable with USB 3.X speeds, you should be able to connect the two laptops together via their Thunderbolt ports, which will wake the controllers and result in emulated 10GbE networking in between them. If they are both Linux then you will have to "sudo modprobe thunderbolt-net" on one of them.

| improve this answer | |
0

I can confirm the HP Thuderbolt dock works with Ubuntu 19.4.

Running an Intel (Disco)Nuc so far loving it all

Settings

lsb_release -a
    No LSB modules are available.
    Distributor ID: Ubuntu
    Description:    Ubuntu 19.04
    Release:        19.04 
    Codename:       disco
| improve this answer | |
  • I've authorized the thunderbolt device, but no displays show up. I have the same output of lsb_release -a as you though. – Billy Ferguson Jun 26 '19 at 19:25
  • Did you need any additional drivers/packages other than bolt. – Billy Ferguson Jun 26 '19 at 19:30
  • Which HP Thunderbolt dock? – highsciguy Jul 16 '19 at 12:41
0

If you tried installing bolt but still couldn't resolve it due to whatever reason. The solution is simply to try upgrading your kernel to newer versions, try different versions to kernels and see which one is supporting the Thunderbolt, this is how I solved it. (I'll suggest you to disable secure boot from BIOS for this).

| improve this answer | |
0

I had this same issue with my new MSI Prestige A10SC. Luckily I am dual booting Windows and elementary OS 5.1 Hera. The solution was to go onto Windows and make sure I have the Intel thunderbolt software and driver. Using the software you can set CalDigital device to "Always connect". This must be a firmware setting because after doing this, everything worked perfectly on my linux partition.

Hope this helps.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy