The old menu of Archive, Edit etc. is behind the gnome-shell panel and it's very annoying. How do I remove this menu in the top panel? I'm using Ubuntu 11.10 by the way.

Here is the problem.

I hope someone can help.

  • Cinnamon or gnome-classic? – Tachyons Feb 18 '12 at 4:06

By the looks, that's the Ubuntu global menu. To remove it, open a terminal and paste this

sudo apt-get remove appmenu-gtk3 appmenu-gtk appmenu-qt

You may need to restart your computer afterwards. If you wver want them back, simply reinstall the packages.

  • Why he have to remove global menu for just gnome? It will effect unity also if he is a unity user too. , – Tachyons Feb 18 '12 at 4:22
  • Thank you very much!! that was the answer :D Long days and pleasant nights to you. – Manck Feb 18 '12 at 4:23
  • @AboobackerMk I know, it's ridiculous. But i've run into this myself, and it was the only way there seems to be to get around it. If anyone knows of a better way, please let us know! – AClockWorkLemon Feb 18 '12 at 4:29
  • But is it gnome-classic gnome-shell or cinnamon? Installed gnome-shell extension for global menu? If yes disable it via gnome-tweak-tool – Tachyons Feb 18 '12 at 4:37
  • No, it wasn't a real menu, it was just like a background, but this worked fine. And it's gnome shell. I think a part of the classic entered in the shell, but Im not sure why. – Manck Feb 18 '12 at 4:50

Yes there is a better way than removing the appmenu packages. Just type the following:

echo '[ ${DESKTOP_SESSION#ubuntu} = $DESKTOP_SESSION ] && unset UBUNTU_MENUPROXY' | sudo tee /etc/X11/Xsession.d/81ubuntu-menu-proxy

This will fix the gnome-shell problem but not affect Unity, nor Unity-2D.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.