0

I installed python3.5.5 from source using make altinstall. Now I also need python3-dev. However I can not find any info on what version I need to work with 3.5.5. If I google python-dev version for Ubuntu 18.04 it always points me to versions in the apt that are labeled 3.6.x but I assume I need a 3.5.x python-dev.

  • by typing apt search python3.5-dev : python3.5-dev/xenial-updates,xenial-security,now 3.5.2-2ubuntu0~16.04.4 amd64 [installed, automatic] Header files and a static library for Python (v3.5) on an Ubuntu 16.04. You can installed python3.5-dev by typing sudo apt install python3.5-dev – damadam Jul 5 '18 at 7:06
  • 1
    E: Unable to locate package python3.5-dev I don't have 16.04 I have 18.04, so your solution won't work for me. – Roy Jul 5 '18 at 12:30
  • did you try apt search python3.5 ? Sure, all package from 16.04 and 18.04 aren't same, but python3.5 or more are on 18.04 – damadam Jul 5 '18 at 12:43
  • Like I said, when I used apt search python3.5-dev all I got was: E: Unable to locate package python3.5-dev – Roy Jul 25 '18 at 11:46
0

try this one:

sudo add-apt-repository ppa:deadsnakes/ppa
sudo apt-get install python3.5-dev

I found this at: Install Tensorflow 1.8.0 with GPU from source on Ubuntu 18.04 Bionic Beaver, hope this work for you :)

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.