1

This question already has an answer here:

I have a Dell Precision Tower 5810, and I was trying to install Ubuntu 18.04 on it. I created a bootable usb with Roofus 3.1 in Windows 10 (as described here).

Then tried to follow Dell's guide here, but I could not find the file SHIMx64.EFI...

Still I made sure the Secure Boot was enabled, the Legacy Option ROMs was not enabled, and the Boot Option was set to UEFI, pushed my usb stick to the top in the Boot Sequence, and exited.

It booted with no problem to my usb stick, showing the options "Try Ubuntu", "Install Ubuntu", etc. But whichever option I used, led me to a blank screen...

Eventually, thanks to this, I added the nomodeset option and I could access the "Try Ubuntu" option... I installed Ubuntu and the installation went through with no problem at all.

Now Ubuntu boots, but the instant the login screen shows up, the screen goes blank (without even letting me type my credentials). I tried pressing the Right Shift key like specified here, but to no avail. I checked all the "Similar Questions" suggested, but none of them work.

Note that the first time I booted after the fresh install, I saw a "Perform MOK management" screen with the following options, but I just selected "Continue to boot".

Any clue anyone? I really need this computer working (with Ubuntu 18.04 if possible) asap! Many many thanks.

marked as duplicate by David Foerster, Eric Carvalho, Fabby, Thomas, Kevin Bowen Jul 18 '18 at 20:07

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Did you try this particular answer from AskUbuntu threads you've linked in your question? – Shashanth Jul 5 '18 at 3:56
  • 1
    Yes, nothing happened... it is not a brightness problem, the computer seems to go to sleep – DaniCee Jul 5 '18 at 4:16
  • OK I seem to have been able to set nomodeset to boot after install from the grub command line pressing Esc, following the instructions at linux.com/learn/how-rescue-non-booting-grub-2-linux%20 – DaniCee Jul 5 '18 at 5:56
  • That question (Black/purple screen after you boot Ubuntu for the first time section) did not solve my issue, cause the<kbd>Right Shift</kbd> did nothing – DaniCee Jul 6 '18 at 5:28
0

The key to this is the following:

1- Create a bootable stick

2- Boot the stick, and in the menu with the options "Try Ubuntu", "Install Ubuntu", etc, press e and add nomodeset right before quiet splash. Then press F10

3- The stick will boot properly this time. Install Ubuntu, the installation should go through without a problem

4- After installing Ubuntu, when you restart, the screen might flicker and die before you can log in, that is what happened to me.

This answer, in particular the Black/purple screen after you boot Ubuntu for the first time section, provides some solutions, but none worked for me... I tried pressing Right Shift but nothing happened. If that is the case, do the following:

5- If you press Esc while booting, you will go to the grub> command line. Here, and thanks to this link, you can type the following, adding nomodeset like before (type what's after grub>):

grub> ls
(hd0) (hd0,gpt2) (hd0,gpt1) (hd1) (hd2)

grub> cat (hd0,gpt2)/etc/issue
Ubuntu 18.04 LTS \n \l

grub> linux /boot/vmlinuz-4.15.0-23-generic root=/dev/sda2 nomodeset

grub> initrd /boot/initrd.img-4.15.0-23-generic

grub> boot

This will allow you to boot to Ubuntu with no problem!

HOWEVER, with the nomodeset option you will not be able to adjust the screen brightness (as specified here).

I have tried the solutions involving making changes to the /etc/default/grub file, and they all cause that you cannot boot anymore. If anyone has a proper solution for this problem, please let me know, otherwise I will open a new question.

Not the answer you're looking for? Browse other questions tagged or ask your own question.