I have a similar problem to the one reported in this thread., but I'm running Bionic Beaver

My machine is a Dell XPS 13. Wifi is working fine.

In settings -> Bluetooth, I'm told No bluetooth found, plug in a dongle

I've tried to turn the button on the top left corner of the screen from OFF to ON but am unable to do so

The solution below, suggested in in the thread cited above, doesn't do anything

rfkill unblock bluetooth
systemctl enable bluetooth.service
systemctl start bluetooth.service

Here's the output of the various commands requested in other posts:

lsusb; lsmod | grep bluetooth; dmesg | grep firmware
Bus 004 Device 003: ID 0bda:8153 Realtek Semiconductor Corp. 
Bus 004 Device 002: ID 0424:5537 Standard Microsystems Corp. 
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 003 Device 007: ID 046d:c00c Logitech, Inc. Optical Wheel Mouse
Bus 003 Device 005: ID 0bda:4014 Realtek Semiconductor Corp. 
Bus 003 Device 006: ID 413c:2010 Dell Computer Corp. Keyboard
Bus 003 Device 004: ID 413c:1003 Dell Computer Corp. Keyboard Hub
Bus 003 Device 003: ID 04a9:1792 Canon, Inc. 
Bus 003 Device 002: ID 0424:2137 Standard Microsystems Corp. 
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 8087:0a2b Intel Corp. 
Bus 001 Device 002: ID 0bda:58f4 Realtek Semiconductor Corp. 
Bus 001 Device 004: ID 27c6:5385  
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
bluetooth             548864  28 btrtl,btintel,bnep,btbcm,btusb
ecdh_generic           24576  2 bluetooth
[    0.032829] Spectre V2 : Enabling Restricted Speculation for firmware calls
[    5.982838] [drm] Finished loading DMC firmware i915/kbl_dmc_ver1_01.bin (v1.1)
[    7.243912] iwlwifi 0000:02:00.0: loaded firmware version 34.0.1 op_mode iwlmvm


rfkill list all


0: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no
1: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
  • Same problem with my HP spectre x360. It was woring fine last week Sep 11 '18 at 13:51
  • The solution here worked for me in my Dell XPS: askubuntu.com/questions/1032417/… Sep 19 '18 at 8:59
  • 2
    @ArkaSantra, there are several solutions in that thread. The accepted one did not work for me. Was that the one that worked for you?
    – Leo Simon
    Sep 19 '18 at 15:10

Browse other questions tagged or ask your own question.