I'm trying to use gifcurry on Ubuntu 16.04 but I get the following warning which will not allow me to select my mp4 I created in KdenLive.

enter image description here

I installed gifcurry as instructed on the site. It opens up fine.

I also tried installing libav-tools but I still get this yellow error or warning which will not allow me to open my MP4.

Does anyone know how to install the proper decoders so I can open my mp4 file? Is there anyway to simply install a whole lot of them which will probably cover it for my mp4?

  • This may be better answered by gifcurry's support or community since as far as I can tell it's not software included with Ubuntu – thomasrutter Jul 4 '18 at 23:24
  • Probably, but if anyone know how to install more decoders into ffmpeg, that would help a lot. – capdragon Jul 4 '18 at 23:26
  • Even their snap has the same error about ffmpeg, it shouldn't as it's provided in the snap. What you can try is from the gifcurry page you linked, github.com/lettier/gifcurry#i-use-linux click on the 'prebuilt version' link. After downloading extract. Inside the extracted folder there will be a bin folder. Drop the gifcurry_gui file into a terminal, press enter. Make sure the main gstreamer1.0 plugins are installed (gstreamer1.0-plugins-bad, gstreamer1.0-plugins-ugly, gstreamer1.0-libav & also gstreamer1.0-gtk3 – doug Jul 4 '18 at 23:46

i'm running ubuntu 18.10, same error using the snap

sudo snap remove gifcurry

download gifcurry AppImage and the 'handy' AppImage install script https://github.com/lettier/gifcurry#i-use-linux-penguin

chmod +x ./gifcurry-app-image-install.sh

launch ./gifcurry-app-image-install.sh

on launch i had one error, fixed by the gstreamer plugin install listed here: https://github.com/lettier/gifcurry/issues/23

| improve this answer | |

According to gifcurry's website, gifcurry requires FFMPEG 3.0 or above. Ubuntu 16.04 only has FFMPEG 2.8.

This may or may not be your issue, but you may want to ask for help from gifcurry's support for further clarification.

| improve this answer | |
  • +1. I did try uninstalling FFMPEG 2.8 and installed 3.x. But I still get the issue. Thanks for the suggestion. Perhaps I should stop being lazy and upgrade Ubuntu to 18.04. – capdragon Jul 5 '18 at 15:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.