This question already has an answer here:

I have an issue with upgrading my laptop to ubuntu 18.04 It's slow and not working well in many things( sometimes restarts on its on, slow while using it, freezes, does not detect the usb) all of these things, not always happining, but randomly. I've tried to reinstall it many times, but the result is same. So when I reinstall it, I found that still there are some files in the directory which I've downloaded before! So I've decided to wipe the hard disk with zeroes using dd command. And suddenly when I type it in terminal.. I've got black screen with only hyphen sign in it for almost 30 minutes now. So my question is.. Is that what I supposed to get? And how long it does usually take to finish?

Given:: Using bootable usb stick. And 500gb hard drive which I'm trying to wipe with zeroes.

marked as duplicate by Terrance, dessert command-line Jul 4 at 19:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • dd wipe on 500 gb hard disk is going to take a long time if you use smaller block sizes. There is no output from dd until complete. Using larget block sizes will make it faster. Best case scenario with optimum block size may wipe at 100MB./sec, that will still take 500000/100/60 = 83 min – Bernard Wei Jul 4 at 19:00
  • That means the black screen is good thing? I've used this command # dd if=/dev/zero of=/dev/sdX bs=4096 – Ahmed Alhisaie Jul 4 at 19:30
  • It won't be blank, just no output following the dd command until it has completed. By then you will get the prompt back. 4k block size is going to be slow, see askubuntu.com/questions/523037/… See link from @Terrance above for status printout if you need to monitor the progress – Bernard Wei Jul 4 at 22:54
  • Maybe something went wrong I don't know I'm not really experienced at this.. Anyway I forcly switched the laptop off, then I run it again, using ubunu live usb, I checked Disks, it showed to me that volumes 500 GB Unknown, so I think it worked but in slow rate and perhaps I crushed it by switching it off by force .. However I run it again using this command sudo dd if=/dev/zero of=/dev/sda bs=4M status=progress oflag=dsync this command much better, it's showing the copying rate and speed! And in just like 20 minute or so it's almost 100GB already copied – Ahmed Alhisaie Jul 5 at 4:42