0

Using Ubuntu 16.04 LTS. The Alfa AWUS036ACH didn't work out of the box with Ubuntu, so I Googled around and found a shell script that got it to work. It worked fine for about two weeks and then suddenly stopped working.

Here is the shell script:

#!/bin/sh

# Shell script to set up drivers for Alfa AWUS036ACH
# You must have an internet connection.

# update your repositories
apt-get update

# install dkms if it isn't already
apt-get install dkms

# change directory to /usr/src
cd /usr/src

# if you have any other drivers installed,remove them like so:
rm -r rtl8812AU-4.3.22/

# get latest driver from github
git clone https://github.com/aircrack-ng/rtl8812au

# move into downloaded driver folder
cd rtl8812au/

# update files in working tree to match files in the index
git checkout --track remotes/origin/v4.3.21

# make drivers
make

# move into parent directory
cd ..

# debugging
dkms status

# rename file for use with dkms
mv rtl8812au/ rtl8812au-4.3.22

# build drivers
dkms build -m rtl8812au -v 4.3.22

# install drivers
dkms install -m rtl8812au -v 4.3.22

# debugging
lsmod

# summon new interface from the depths of the kernel
modprobe 8812au

# wifi interface should now appear.
ip link

The adapter worked just fine for about two weeks and then one day it suddenly stops working or being detected by my OS. Neither iwconfig nor ifconfig will show it. Just to check that it wasn't an issue with the Alfa adapter itself, I plugged it in to a Windows PC and it worked just fine. Please help me get it working again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.