2

I've installed Lubuntu 18.04 on my wife's desktop, and yes, she's that kind of user which types capslock to ponctually type uppercase characters...

Here is the problem : I have a french keyboard (PS/2 Logitech with multimedia buttons). Lubuntu detected it as "french azerty (obsolete)".

  • When I type Shift a, it gives me A
  • When I type Capslock then a, it gives me A
  • When I type Shift ;, it gives me .
  • When I type Capslock then ;, it gives me ;

I tried to change the keyboard to "french azerty (variant)" but no change on the punctuation. The quite good indicator is that the top-left key under escape type either æ or ².

Do other french users had the same problems ?

6
  • Yes, but it didn't bother me, I think it can be change into System parameter -> Keyboard – damadam Jul 4 '18 at 8:36
  • 9
    I don't think the CAPS LOCK is supposed to work on non-letters. – Jos Jul 4 '18 at 8:36
  • 2
    Capslock has no effect on keys other than letters. It means there would be no effect of capslock on number keys., punctuation keys or numpad. – Kulfy Jul 4 '18 at 8:41
  • 3
    @Goufalite not on my Windows 10 (US keyboard), and not on any other Windows system or keyboard I have used in the past 15 years. – muru Jul 4 '18 at 9:53
  • 6
    Possible duplicate of How can I remap the Caps Lock key to be Shift Lock? – David Foerster Jul 4 '18 at 11:50
5

From How can I remap the caps lock key to be shift

  1. Install gnome-tweak-tool:

    sudo apt install gnome-tweak-tool
    
  2. Start gnome-tweak-tool:

    gnome-tweak-tool
    
  3. Change the CapsLock behavior from Deactivated to CAPS Lock activate the Shift Lock

    default tweak tool CAPS Lock is SHIFT Lock

You can now type 1234 with CapsLock (but be careful, Shift + Mouse on an application icon open a new window).


UPDATE for 18.04:

  1. Start gnome-tweaks

    gnome-tweaks
    
  2. Go to Keyboard & mouse -> Additional Layout Options (refered as Options supplémentaires d'agencement on my screenshot) -> CapsLock Behavior

enter image description here

  1. Change CapsLock from Desactivated to Use CapsLock as Shift (there are some different options, test and choose which one fits to your use)
2
  • Since this is Lubuntu, I don't think gnome-tweak-tool would be the appropriate tool here. – muru Jul 4 '18 at 12:11
  • Works on Lubuntu, but you must type gnome-tweaks instead... Quite buggy (hangs and crashes) but furthermore doesn't solve my problem even after a reboot – Goufalite Jul 5 '18 at 17:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.