After recently upgrading my media center to 10.04 (for the LTS) and making lots of updates which may have overwritten stuff (configs), the login was impossible at the name selection menu.

VNC doesn't work either, it says the server refuses the connection. (10061) On the other hand, I can still connect to the server via SSH, and the Samba shares are unaffected.

When I try to login at the computer itself, the screen flashes black a few times and it then brings me back to the name selection menu.

Via SSH, I tried deleting the xauthority file from the /home directory, renaming it and rebooting afterwards didn't do it either.

I tried reinstalling gdm to no avail.

Can someone explain the difference between X and gdm?

  • I'm wondering if I still have both gdm and X installed. How do I check with CLI? – Simon Feb 17 '12 at 23:18

I had a similar problem with my notebook. My solution was to purge compiz: sudo apt-get purge compiz* After the restart, I could simply log in (there was a problem with the video driver).

X vs gdm:

  • X contains the whole graphical subsystem, basically it does the communication with your hardware
  • GDM is the Gnome Display Manager, it manages the graphical sessions. It is like the tty, creates a new session, and you log in with a user+pass, but with graphics. Similar tools are kdm, lightdm, xdm.

Sorry, I don't know how to check whether gdm and X is installed. You can restore the full working desktop with all the packages sudo apt-get install ubuntu-desktop and then remove the unwanted in the next step

  • This didn't work for me. – weberc2 Jan 10 '15 at 20:39

I fixed my similar login loop issue thanks to https://askubuntu.com/a/63697/42522

sudo dpkg-reconfigure -phigh xserver-xorg

X is like an old buggy DirectX, and GDM is like Windows Explorer telling it what to display.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.