3

The Ubuntu 18.04 LTS installation (with 4.15.0-24-generic x86_64) in our living room fails to boot to the login screen. Some other Ubuntu installations in our flat are still working alright (they should be on the same patch level). I used the borked one this morning and it was working okay. Afaik no updates or anything. Normal shutdown around lunch. When I tried to boot it again a couple hours later, it keeps hanging.

After power up, it first hangs a while on the screen with the logo and the dots (no dots move, only the first one is ever shown). After about half a minute or so, it drops to the boot messsages; here is what's shown last:

[ OK ] Started GNOME Display Manager.erver.tcher Service......tem changes.pp link was shut down....

After that, nothing.

I can Ctrl+Alt+F2 to a tty login. I can then log in, ping Google, use apt, etc. I updated everything and rebooted, but it didn't change anything. Reinstalled gdm3 and GNOME, still nothing.

Any hints?

  • I too have this problem ... just started after installing latest updates. – Kolban Jul 4 '18 at 14:26
  • Me too . Please share if you found an answer – Delosari Jul 14 '18 at 22:10
1

Have a look at this link: https://www.linuxuprising.com/2018/07/ubuntu-1804-linux-kernel-update-causes.html

Kernel image 4.15.0-24 is said to have caused this issue on some systems.

A patch is said to be available. However, the new kernel image package is not yet available in the 'updates' repo. It's still in 'proposed'.

What also helped for me is installing haveged (user space entropy gathering daemon).

I have two PCs with the same hardware that refused to boot. On the first one, I installed the proposed kernel. On the second one, I just installed haveged. Both solutions solved the boot issue.

See this bug report on Launchpad for reference: https://bugs.launchpad.net/ubuntu/+bug/1779827

  • Thanks, this looks promising. Will try it out tomorrow, and report here. – Brutus Jul 6 '18 at 9:00
  • I skipped testing the mentioned Kernel, because the suspected reasons for this bug have shifted towards entropy generation. See the recent discussion at the links you provided. Since I only have SSDs installed (no spinning disks) I tried installing haveged, which works for me. You might want to update your answer, although until now, there seems to be no clear solution for this. – Brutus Jul 8 '18 at 11:28
  • @Brutus please, how did you installed haveged? Myself I am stuck in the boot screen. – Delosari Jul 14 '18 at 22:11
  • @Delosari I used Ctrl+Alt+F2 to switch to a tty. From there I logged in with my username & password and ran sudo apt install haveged. Now the boot process is faster. Alternatively, random typing and mouse clicks / movement seem to speed up the boot process too, down to about 4 to 5 minutes from power on to the Gnome login screen. – Brutus Jul 16 '18 at 9:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.