1

I'm trying to install a stripped down version of LUbuntu on a USB flash drive. I previously tried installing the standard install as well as the "minimal" install and they both failed due to running out of space on a 4GB flash drive (strangely, at the exact same spot, as if the "minimal" install was being ignored).

To be clear, I am trying to install from one USB flash drive to another. I don't have any other devices I can use.

I downloaded the latest (18.04) mini.iso file from this page. However, despite having tried several ways, I cannot get it to boot - when I select the USB flash drive as the boot drive in my BIOS, the screen flashes and drops me back in the BIOS boot menu - it won't boot the drive! I have tried several different USB flash drives, including one that booted the full Live USB image. I have tried using the "Live Linux USB Creator". It's pretty self-explanatory, you select your USB key, find the ISO image, it tells you it's going to use generic Linux defaults (Live Mode, hide files) and then you click to start and wait until it's done, then eject the USB flash drive and tried to use it. I have tried using "dd" as per the directions linked from the above page. I have tried UNetbootin which is also pretty self explanatory, the steps are pretty similar to LiLi USB Creator. I also tried usb-creator-gtk and follows its prompts for the same info.

Why can't I boot from the mini image and do a minimal install? With the exact same hardware and software (e.g. same USB flash drive, same program such as LiLi USB Creator or usb-creator-gtk, same machine trying to boot from the drive in the same way) it works for the standard Live USB image - it just refuses to boot the minimal install image!

Update: For the dd method I followed the link from the min-install page above where it said:

Unlike other iso images available on this site, older versions of the mini.iso do not work from USB drives, but you can make a working USB install drive with the dd cloning method with the mini.iso version 13.04+. See this link and this tutorial.

When I followed "this link" I got this dd command which was reported to work:

dd if=/home/username/Downloads/mini.iso of=/dev/sdc

I replaced the input file and output device with my own:

$ sudo dd if=mini.iso of=/dev/sdb 
64+0 records in
64+0 records out
67108864 bytes (67 MB, 64 MiB) copied, 41.7327 s, 1.6 MB/s

(mini.iso on cwd was downloaded from here) I also tried in a subsequent attempt appending " bs=1M" to the end of the dd command, although as expected that made no difference.

If I look at the USB flash drive after the dd it looks like this:

$ sudo fdisk /dev/sdb

Welcome to fdisk (util-linux 2.27.1).
Changes will remain in memory only, until you decide to write them.
Be careful before using the write command.


Command (m for help): p
Disk /dev/sdb: 240.5 MiB, 252182528 bytes, 492544 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6da8bcf7

Device     Boot  Start    End Sectors Size Id Type
/dev/sdb1  *         0 118783  118784  58M 17 Hidden HPFS/NTFS
/dev/sdb2       118784 131071   12288   6M  1 FAT12

Command (m for help): 

So it definitely looks like the device is marked as bootable in some way.

Update 2: I tried both UEFI and legacy modes, neither made any difference.

I also tried to boot the USB flash drive in a VM under Parallels and it also didn't work - it basically went to a black screen for several seconds before giving up and booting to the default VM image. When I tried to boot a Live USB (full) image under Parallels it worked fine, bringing up a menu for how to boot up.

  • @user535733 i just followed the directions exactly as I found them... it's rather frustrating to waste four hours on this and then be told that I'm doing something wrong and have to waste another how many hours trying to exactly go through and document exactly what I did... A lot of it is pretty self explanatory and hard to get wrong, anyway. – Michael Jul 3 '18 at 17:27
  • @user535733 And the tools don't "just" work either. Apparently with Linux Live USB Creator you have to have a perfectly partitioned and formatted USB flash drive, as once I created anything on the drive in Linux (e.g. tried to install Linux or something on it) it wouldn't even show up in the list of keys. That any many other frustrations. – Michael Jul 3 '18 at 17:29
  • 2
    I completely agree that it's frustrating when something doesn't work...but I just used dd to create a working LiveUSB using the minimal .iso. It works. What did you do different from me? – user535733 Jul 3 '18 at 17:30
  • @user535733 I have updated the question to include the command and output of the dd command – Michael Jul 3 '18 at 18:55
  • 1
    Please specify your computer (brand name and model). Are you booting in UEFI mode or BIOS mode(alias CSM alias legacy mode)? The Ubuntu mini.iso will only boot in BIOS mode. If you want to do something similar in UEFI mode, you can start from the classic Ubuntu Server iso file with the old debian installer (that looks like the installer in mini.iso. – sudodus Jul 3 '18 at 20:42
2

I have no idea why the image wouldn't boot in non-UEFI mode under a VM. However, in "legacy mode" it appeared to not want to boot. The screen went black for several seconds, and then it went back to the POST screen like the boot failed. When it did this the first time I assumed it had tried, failed, and had given up and was going to try to boot back into Windows so I entered setup again. However, after a suggestion by sudodus, I tried again, and this time I somehow failed to hit the right key to enter setup and the install process just started!

So the answer is: the mini.iso won't boot in EFI (Secure Boot) like the regular Live USB will. It instead requires disabling secure boot using using Legacy mode.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.