1

I want to install texlive-full using Ubuntu 18.04 on top of Windows 10 RS3 using the WSL. This is a clean system without any additional repository. The installation failed as follows:

$ sudo apt install texlive 
....
Errors were encountered while processing:
 /var/cache/apt/archives/texlive-fonts-extra_2015.20160320-1_all.deb
 /var/cache/apt/archives/texlive-fonts-extra-doc_2015.20160320-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

So then, I retried to double-check the error messaging

$ sudo apt install texlive-full
Reading package lists... Done
Building dependency tree
Reading state information... Done
texlive-full is already the newest version (2015.20160320-1ubuntu0.1).
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 texlive-full : Depends: texlive-fonts-extra-doc (>= 2015) but it is not going to be installed
                Depends: texlive-fonts-extra (>= 2015) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

And then followed the suggestion from the tool to use apt-get -f install to fix it. However, the command does not fix the problem

$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following additional packages will be installed:
  texlive-fonts-extra texlive-fonts-extra-doc
The following NEW packages will be installed:
  texlive-fonts-extra texlive-fonts-extra-doc
0 upgraded, 2 newly installed, 0 to remove and 38 not upgraded.
240 not fully installed or removed.
Need to get 0 B/303 MB of archives.
After this operation, 746 MB of additional disk space will be used.
Do you want to continue? [Y/n]
(Reading database ... 150355 files and directories currently installed.)
Preparing to unpack .../texlive-fonts-extra-doc_2015.20160320-1_all.deb ...
Unpacking texlive-fonts-extra-doc (2015.20160320-1) ...
dpkg: error processing archive /var/cache/apt/archives/texlive-fonts-extra-doc_2015.20160320-1_all.deb (--unpack):
 unable to create '/usr/share/doc/texlive-doc/fonts/electrum/manifest.txt.gz.dpkg-new' (while processing './usr/share/doc/texlive-doc/fonts/electrum/manifest.txt.gz'): Permission denied
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Preparing to unpack .../texlive-fonts-extra_2015.20160320-1_all.deb ...
Unpacking texlive-fonts-extra (2015.20160320-1) ...
dpkg: error processing archive /var/cache/apt/archives/texlive-fonts-extra_2015.20160320-1_all.deb (--unpack):
 unable to create '/usr/share/texlive/texmf-dist/tex/latex/electrum/ts1yes1.fd.dpkg-new' (while processing './usr/share/texlive/texmf-dist/tex/latex/electrum/ts1yes1.fd'): Permission denied
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/texlive-fonts-extra-doc_2015.20160320-1_all.deb
 /var/cache/apt/archives/texlive-fonts-extra_2015.20160320-1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

There seems to be some problems with permissions according to the errors (unable to create file messages among all this output) but I can't see how to fix this. Any idea?

Now, whenever I try to install anything through apt it complains that I have to fix this dependency, but I cannot.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.