10

When I used Linux Mint earlier I never faced a problem with printing on GIMP (because it was installed and configured by default).

When I used Ubuntu 18.04 LTS, I installed GIMP 2.10 from the software center. Everything is working fine on GIMP except printing.

The GIMP print window does not list my printer (or any other printer). I can only see:

  1. Print to File
  2. Print to LPR

enter image description here

I tried couple of troubleshooting tips without any success. I'm sure that the problem is from GIMP because I can print from Chrome /Firefox and from PDF reader without any problems.

PS: I don't know if this help but in the software center I found printing documents permission disabled for GIMP. I tried to enable it, but it gets automatically disabled again every time.

enter image description here

Any info/tips are highly appreciated.

2
  • 1
    Is the gimp-gutenprint package installed? Jul 3, 2018 at 12:01
  • I'm not sure but - what if you have GIMP installed from Snap? Please add outputs of apt-cache policy gimp and snap list gimp to the question.
    – N0rbert
    Jul 3, 2018 at 20:33

4 Answers 4

8

It sounds like you have the "Snap" version of GIMP installed...

When you search for GIMP in Ubuntu Software, you should see two results if you're using Ubuntu 18.04 LTS ("Bionic Beaver") or newer:

GIMP in Ubuntu Software

If you cannot see two versions of GIMP, you will need to enable "Community-maintained free and open-source software (universe)" by searching for "Software & updates" in the menu (its icon looks like a cardboard box with a globe/Earth), then make sure there is a "tick" in the box that says "Community-maintained free and open-source software (universe)":

Software & Updates

Snap packages often have problems with "seeing" hardware - at least in my experience - so I'm guessing you've probably installed the Snap version of GIMP... Install the "traditional" version of GIMP (i.e. the other result) instead.

The "Snap" version will have "Snap Store" listed under "Source":

Snap version of GIMP

Whilst the "traditional" version of GIMP will have "ubuntu-bionic-universe" listed under "Source":

traditional version of GIMP

Just don't forget to remove/uninstall the Snap version of GIMP first - otherwise you'll have two copies of the same program installed and two icons in the menu! You can do this by selecting the "Snap" version of GIMP in Ubuntu Software.

3
  • Looks like idea hijack (see my comment above), but well-played and well-done! :)
    – N0rbert
    Jul 3, 2018 at 21:16
  • 1
    I was probably still typing my post when you put that up - there was only one comment when I first started (the other comment)... Too busy running around getting screenshots. Jul 3, 2018 at 21:32
  • Perfect that solved the problem , thanks a lot. anybody tell us the difference between the two GIPM version ?
    – Alexander
    Jul 4, 2018 at 11:52
6

Before removing snap's gimp, you can try this suggestion.
TL;DR: run

$ sudo snap refresh gimp --edge
$ sudo snap connect gimp:cups-control

Worked for me.

1
  • I'll better remove snap as it's has usability bug -- not working out of the box. Apt is more human-friendly.
    – gaRex
    Dec 17, 2021 at 15:22
2

I also installed the snap version but I was able to turn on the Print Documents permission in the Permissions dialog after which my printers showed up. Try to exit GIMP before attempting to change the permissions. I had a similar experience to yours with the Read/Write files on removable storage devices permission where it snapped back to off after I turned it on but after few attempts is stayed on.

1
  • This worked for me. For the uninitiated, in Ubuntu 21.10, open Settings, then Applications, then find GNU Image Manipulation Program. Dec 31, 2021 at 0:51
1

The permission tab in the software installation process is key. This solved a long standing problem in GIMP for me but also in several other snaps including Thunderbird.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.