This question already has an answer here:

I'm using following wifi hardware (08:00.0 Network controller [0280]: Broadcom Limited BCM43142 802.11b/g/n [14e4:4365] (rev 01))

       description: Network controller
       product: BCM43142 802.11b/g/n
       vendor: Broadcom Limited
       physical id: 0
       bus info: pci@0000:08:00.0
       version: 01
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list
       configuration: latency=0
       resources: memory:c1500000-c1507fff

This has just stopped working after recent update by Ubuntu which made me auto remove few files as they weren't needed.

I have tried following links none worked: Installing Broadcom Wireless Drivers https://grenangen.se/node/86

Kindly help


marked as duplicate by Pilot6, karel, Community Jul 6 '18 at 8:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • What is the kernel version? – Pilot6 Jul 5 '18 at 19:57

Like @Juxmix said, I disabled the proprietary driver, restarted and it didn't work. Then I executed the following command:

sudo apt-get install firmware-b43-installer

and it worked.

EDIT: The wifi with the b43 firmware was running a little bit slower then Broadcom one.

  1. disable the networking
  2. uinstall the b43 drivers

    sudo apt remove firmware-b43-installer

  3. follow the instructions on this link

  • i already have its newest version :( – Shivak Singh Jul 4 '18 at 14:17
  • Did you disable the proprietary driver? – Shonen Jul 5 '18 at 15:50
  • Yup I have disabled it and uninstalled it as well – Shivak Singh Jul 6 '18 at 8:40
  • Glad to hear it worked. – Shonen Jul 14 '18 at 8:34

I had the same problem with the same network controller, after updating. Tried winding back to an earlier version, network restart... Nothing worked.

What worked uninstalling "our" 16.04 version of the broadcom drivers:

sudo apt-get remove --purge bcmwl-kernel-source

Then installing the 18.04 binaries which can be found here:


With this command or simply opening the file with the software center.

sudo dpkg -i bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu4_amd64.deb

The original source, from another part of Stackexchange can be found following this link:


  • the second command is not working on ubuntu16.04 and I don't know how to download the package directly from ubuntu packages – Shivak Singh Jul 5 '18 at 7:40

I have the same Wireless card and have faced similar issue immediately after installing Ubuntu 16.04.

Please go to 'Additional Drivers' tab in 'Softwares & Updates'. Check if your wireless card is listed and ensure that it is using the proprietary drivers from Broadcom.

enter image description here

If the device is not listed or driver is not found, connect your system to Internet using a wired connection and install all updates using 'software updater'.

Run sudo apt-get update to refresh all the repositories.

For me, automatically found the proper drivers and the Wi-Fi started working after a restart. Hope this solves your issue.

  • thanks for your comment but the device is listed and with update i meant recent updates issued by ubuntu16.04 – Shivak Singh Jul 3 '18 at 9:47
  • So even with proprietary driver it's not working? – Jrct Jul 3 '18 at 9:49
  • yup it isn't working – Shivak Singh Jul 3 '18 at 15:30
  • ohh ok. Lots of people with this WiFi card are facing this issue after yesterday's update. – Jrct Jul 4 '18 at 5:33
  • I have tried almost everything seems like there is no new post regarding this. – Shivak Singh Jul 4 '18 at 6:54

I had the very same problem and I solved by selecting "Do not use this device" on the control panel. After appling and restarting it began to work fine. By the way the name of the wireles interface has changed to something like wlp2s0b1

  • I tried this as well no success – Shivak Singh Jul 4 '18 at 3:21

Not the answer you're looking for? Browse other questions tagged or ask your own question.