3

Ubuntu 18.04 Version 67.0.3396.99 (Official Build) (64-bit)

By monitoring

systemd-inhibit --list

I have come to the surprising conclusion that a newspaper website I visit in Chrome is placing an inhibit which blocks suspend.

When I use uBlock adblocker, it doesn't do this.

This is the block:

 Who: tim (UID 1000/tim, PID 16532/gnome-session-b)
    What: shutdown:sleep
     Why: user session inhibited
    Mode: block

I believe this means it blocks sleep. My laptop is not sleeping despite the power settings.

and all I have to do is create this block is to turn off uBlock and reload https://www.theage.com.au/

To remove the block, I reenable uBlock and reload. Laptop then suspends.

This site does not have notification permission enabled in Chrome.

I wonder how I can control this. Can I block Chrome from sending inhibit messages?

Update: it is this bug: https://bugs.launchpad.net/ubuntu/+source/gnome-session/+bug/1600622

For reference

sudo systemctl -i suspend

will suspend, over-riding inhibitors (-i means ignore inhibitors)

  • I think Chromium/Chrome does this when there are active websockets – Tim Richardson Feb 15 at 4:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.