Recently I installed LibreOffice 3.5 from debs (including the ones for desktop integration. Since then it behaves in a weird manner. Basically it won't launch from launcher shortcuts. Example:

  • dash > libreoffice launched (launcher shows with 2 seconds delay) > 'keep in launcher'
  • LO closed
  • the LO icon on the launcher clicked > pulsating for 5 seconds, then stops > LO didn't launch
  • I didn't look for open processes or anything and...
  • dash > libreoffice launched immediately without problems

It also didn't remember recently opened items, but now it got fixed somehow.

Other symptoms:
- icon on the launcher and all menu categories appear with a delay of few seconds
- two writer icons appear on the launcher

What I did:

I don't know if it is related but I use Unity test PPA:vanvugt/unity which I needed to solve the stuttering windows bug.

Any ideas?

  • 2
    Libreoffice PPA doesn't have 3.5 it's at release 3.4.5
    – fragos
    Feb 18, 2012 at 1:56
  • Did you use the sudo apt-get to install as well? Also you are always better off downgrading an application when it's not working correctly than you are upgrading. Downgrading to better know and more stable versions are the smarter choice. I will edit my response if you respond. Feb 24, 2012 at 4:09
  • OP are you still looking for an answer?
    – Ringtail
    Feb 26, 2012 at 3:24
  • The problem still exists, even on my clean install of Ubuntu 11.10 and LO 3.5.* from ppa:libreoffice/ppa. The official repository is still stuck with 3.4.*
    – Bucic
    Mar 27, 2012 at 22:20
  • The problem seems to be gone as I see it now in 12.04 as of September 2012 and I didn't care to try the solutions proposed here, sorry. Do any of the answers above contain a definite answer? I'd like to mark the question as answered if that's the case.
    – Bucic
    Sep 14, 2012 at 18:02

2 Answers 2


Open Ubuntu Software Center. Search For LibreOffice Writer. Click on "Info" then See the bottom of Software Center. There is a Add to launch bar option. Try that.


If you have installed from .deb files, libreoffice filename will be libreoffice3.5-writer. So you need to edit the file ~/.local/share /applications/libreoffice-writer.desktop and change the executable filename to libreoffice3.5 -writer . Find and change Exec=

[Writer Shortcut Group]
Exec=libreoffice3.5 -writer %U
  • The question is specifically about launcher shortcut and you seem to pint to a desktop shortcut which I, for example, don't plan to create. Could you provide the solution in 'launcher variant', please? :)
    – Bucic
    Feb 28, 2012 at 20:00
  • @Bucic: Launcher icons are essentially files with extension ".desktop" . : ). Please try my solution and let me know. Also to be doubly sure of the filename,open synaptic and search for libreoffice. It will show up the installed files with file names.
    – Ubuntuser
    Feb 29, 2012 at 4:03
  • Sorry, but the location specified by you does not contain any libre files on my system. Only some wine files. / The only hint I've managed to dig out from terminal was "** WARNING **: Couldn't call /com/canonical/AppMenu/Registrar.UnregisterWindow" after running "sudo libreoffice --writer" and closing it.
    – Bucic
    Feb 29, 2012 at 21:07
  • Firstly, you do not need a sudo for running libreoffice. Easyway to find libreoffice writer file from the terminal is to type libreoffice in the terminal and press the "Tab" key. It will give you the available options for libreoffice. If you do not have a desktop file, create one for libreoffice. I will give you one.
    – Ubuntuser
    Mar 2, 2012 at 1:44
  • type the following command in the terminal gedit ~/.local/share/applications/libreoffice-writer.desktop and paste the following code in the file. pastebin.com/VwiRPZeH. Then save it. Make sure to change the Exec section to corresponding file name.
    – Ubuntuser
    Mar 2, 2012 at 1:48

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .