2

Since some weeks, several keys of my keyboard started to hang from time to time on Ubuntu 18.04. This means that sometimes the key I pressed last is pressed until I hit another key. This mainly happens when I hit the same key several times (e.g. the arrows for navigation). I know, obviously, this sounds like a hardware problem, but when I boot the Laptop in Windows 10, this problem does not occur. So I suspect it might be related to the keyboard driver used in Ubuntu 18.04.

Does anyone have a suggestion which log-files could tell me more or what I could try?

PS: I use Ubuntu 18.04 64-bit on my Thinkpad E480.

Edit: I still have no solution for this problem but I think, some additional information could be useful:

  • this problem does not occur when I plug in an external keyboard, only the build-in Thinkpad keyboard is affected
  • this problem does not occur when I boot in recovery mode, but in Wayland and GNOME Classic, it occurs as well

This brings me to the conclusion that it is not related to the hardware (otherwise it should occur in Windows and recovery mode as well) or general Ubuntu setting (otherwise it would occur with the external keyboard as well). In my opinion, it seems to be related to the keyboard driver, used for the build-in keyboard, which is loaded by Xorg but not in recovery mode.

Edit 2: I recently found a strange workaround. When the power cable (USB-C) is unplugged, hanging keys are gone. This problem only occurs while the cable is plugged in. Obviously, this is a problem with the driver.

  • Looks like the key is 'latching'. – Graham Jul 2 '18 at 16:27
  • Yes, it looks like. However, this behaviour does not occur in Windows, so it must be software-related. I tried around a bit. I get the same behaviour even when I boot in a Live-System in Ubuntu and also Kubuntu. – Ludwig Jul 2 '18 at 17:13
  • By the way, it occurs mostly for the "back", "del" and the arrow keys, so all keys you hit several times at once. Then they get "locked" and continue even if you do not press any more. – Ludwig Jul 2 '18 at 17:17
  • Have you looked at this thread regarding sticky keys? askubuntu.com/questions/880740/… – Graham Jul 2 '18 at 17:43
  • Sounded very promising but in "System settings -> Universal access", in "dconf-editor" and in xkbset (using "xkbset q") sticky keys are switched off. – Ludwig Jul 2 '18 at 20:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.