0

I've installed 18.04 and updated the BIOS to 44.
I've tried adding nomodeset to the end of the linux line.
I've tried kernels 4.17.3 and 4.18-rc3 too. I've tried running off each individual stick of RAM and both together.

It freezes with just the text:

Loading Linux 4.15.0-23-generic
Loading initial ramdisk

Annoyingly, the Live CD just runs fine with nomodeset, but the installed version apparently doesn't, although I can chroot it from the live CD, fetch updates, etc fine.

Any suggestions?

1

I was having exactly the same problem with a NUC8i7hnk, but in my case I was trying to install archlinux. I tried everything possible to solve it with no success.

So, I just gave up grub and tried using systemd-boot as the bootloader. Everything worked in the first try :). I think there is a bug when using GRUB with Intel NUCs

  • I for once decided to use GRUB instead, and then I hit this brick wall. It's not very encouraging haha. So thanks for letting me know as I'll now try to just go systemd-boot instead. – Simon Nov 6 '18 at 15:45
0

Once you set nomodeset in /etc/default/grub did you make sure to run an update?

sudo update-grub

I was able to boot into the new kernel and similarly run video from LLVM-pipe, but I can't get the GPU working (when I remove nomodeset). When I SSH in and run

systemctl status gpu-manager.service

the log yields the following:

gpu-manager[1670]: /etc/modprobe.d is not a file
gpu-manager[1670]: /etc/modprobe.d is not a file
gpu-manager[1670]: /etc/modprobe.d is not a file
gpu-manager[1670]: /etc/modprobe.d is not a file
gpu-manager[1670]: Error: can't open /lib/modules/4.15.0-24-generic/updates/dkms
systemd[1]: Started Detect the available GPUs and deal with any system changes.

Even switching to lightdm didn't help.

Seems to be an issue in gdm3 with starting the xserver. Running the command,

vdpauinfo 

shows:

vdpauinfo: cannot connect to X server 
  • I was editing the menu option at boot time, so no need to update. Pretty certain I was doing that right as the USB live disk needed it to boot. – rich Jul 4 '18 at 7:03
0

I was previously able to install Ubuntu 18.04 and get the GPU working fully by following these instructions: Graphics drivers for Intel NUC Hades Canyon NUC8i7HVK (AMD Radeon RX Vega GH)

Did you make sure to copy over and install the GPU firmware files?

However, that only worked for me in legacy boot mode, which was discontinued after BIOS 0033. In UEFI boot mode I can install 18.04 server/desktop and boot to a stock state (GPU not working, video is coming from LLVM-pipe), but if I install a newer kernel it will not boot and hang at Loading initial ramdisk, it will still boot to 4.15 though.

EDIT (July 12 2018):

I tried a few things differently this time so I'm not sure what fixed it, but here are the steps that worked for me on the HVK today:

  1. Disabled Intel GPU in BIOS
  2. Installed Ubuntu 18.04 Desktop using nomodeset as a grub option during install and regular boot
  3. Updated all packages
  4. Installed latest stable 18.1.3-1 mesa Ubuntu release from this PPA: https://launchpad.net/~ubuntu-x-swat/+archive/ubuntu/updates
  5. Installed daily Ubuntu kernel release (2018-07-09): http://kernel.ubuntu.com/~kernel-ppa/mainline/daily/2018-07-09/
  6. Rebooted (still using nomodeset)
  7. Installed AMDGPU Vega M firmware from: https://people.freedesktop.org/~agd5f/radeon_ucode/vegam/
  8. Removed nomodeset

EDIT 2 (Jul 17 2018):

I tried the same set of steps on a NUC8i7HNK and the machine still hangs at "loading initial ramdisk" after installing the 4.18 kernel. So HVK is fine, HNK has issues, at least with Ubuntu 18.04 + v4.18 kernel. It gets stuck prior to even installing the firmware files.

  • Thanks. I did copy over the GPU firmware files and run update-initramfs. I'd seen, and followed, both posts in that thread a few times over. Were you using the HVK or the HNK? – rich Jul 3 '18 at 8:30
  • Ok. I've got Arch linux working. So I guess there's nothing wrong with the hardware and the principles I followed are the same. Not sure what the issue was. – rich Jul 3 '18 at 11:23
  • I was having trouble with the HNK when not using legacy boot. I've gotten the HVK working in both UEFI and legacy although I'm having trouble getting a desktop running with Ubuntu 18.04 + 4.18rc3 kernel + latest oibaf mesa/drivers and the freedesktop firmware. Which 4.18 kernel did you use? – senorroboto Jul 4 '18 at 1:27
  • It was -rc3 too. Which is the same one that works for me on Arch. – rich Jul 4 '18 at 7:01
  • Updated my original reply post with working steps – senorroboto Jul 12 '18 at 23:09
0

Same problem, or similar I think. Brand new Intel Hades Canyon NUC8i7HNK. Clean install Ubuntu 18.04 Installer seemed to work perfectly. Hung during the install.

[FAILED] Failed to start User Manager for UID 121.
....repeating

Went into BIOS, disabled Intel iGD

Seems to have worked.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.