1

I've been having trouble using Ubuntu on my Dell XPS 15 9560.

I started by installing 17.10 a few months ago but the process didn't seem to work correctly. I was eventually able to log in and use the machine, but got errors of the form "watchdog: BUG: soft lockup CPU stuck" when trying to shut down the machine, and at other times as well. Typically these errors would be accompanied by the entire machine freezing or becoming largely unusable.

To try to fix this problem I recently downloaded and installed Ubuntu 18.04. I reinstalled from scratch. Once the installer was complete, I went to reboot the machine and the installer froze. I did a hard reboot and was able to boot into Ubuntu from disk. However, when I entered my password and logged in the screen remains a dark purple with just the cursor and nothing loads. Using ctrl alt f4 to switch to a command line prompt works, though I frequently see this same error above (soft lockup of CPUs). I've seen other people have this login problem on 18.04 so I've tried following the instructions in the question linked below

Cannot login with upgraded ubuntu 18.04

but updating the software doesn't seem to help.

Does anyone know what might be going on?

1

I was able to follow the instructions here to log in

Lubuntu 16.04 gets stuck at shutdown (nmi watchdog bug soft lockup - cpu#1 stuck for 22s)

and then installed the NVidia graphics drivers. That seems to have fixed the problem.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.