I'm working with a web application which prints receipts reading from a web-server on same machine. As I'm much inclined to open software, I thought to provide the entire pack on Ubuntu. But, knowing almost every clients using a dot-matrix printer from local manufacture, I have to somehow deal with this printing problem.

Ubuntu showed it's name as -TVS MSP-250* in Printers application and then I had to choose the Driver. So I opted for Generic text-only printer.

Tried to print a page from firefox & a page from gedit.

Printer not responded at all!

Reading Epson EX 100 and ESC/P from usb_printerid, I have tried Epson 9-Pin Series make and model.

Then it printed first line of page partially.

From a webpage, it almost printed first line readable in small font-size., on a bigger font, some clipping occures at bottom for letters like g From gedit, it also looks same - only printing bottom clipped first line.

Then, I have tried Epson Dot Matrix Foomatic/epsonc (recommended) from a PPD file downloaded from openprinting That moved printer head, but not printed anything.

Finally I have tried the TVSE9W80COL.ppd file downloaded from printer manufacture.

Product page

Download link

That one also not working.

I can print from root user using:

cat linux.txt > /dev/usb/lp0

It prints quickly, but doesn't care about the page width.

I have called the customer service of the manufacture and they asked me to contact Ubuntu :`(

I have read qz-tray can help. But want to make sure, I can't do anything with the default softwares. I don't know anything about the hardware or drivers, how cups work or does it involves here. Please suggest a good solution that works on Ubuntu.

sudo usb_printerid /dev/usb/lp0

�Վ���                                                                                                                            @���3>
                 ���jA�     @�Վ��
                                                     @  @�Վ��I  @�Վ���؎���؎���؎���؎��:ގ���ގ���ގ���ގ���ގ���ގ���ގ���ގ��ߎ��ߎ��ߎ��/ߎ��`ߎ��rߎ���ߎ���ߎ���ߎ��!��������d@@8 ��I�        @


lpstat -a

TVS-MSP-250 accepting requests since Sunday 01 July 2018 03:17:54 PM IST

ls -l /etc/cups/ppd/

total 4
-rw-r----- 1 root lp 1401 Jul  1 15:17 TVS-MSP-250.ppd


Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 005 Device 002: ID 0e75:1101 TVS Electronics, Ltd 
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 003: ID 046d:c077 Logitech, Inc. M105 Optical Mouse
Bus 004 Device 002: ID 046d:c31c Logitech, Inc. Keyboard K120
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub

lpinfo -v

network beh
network http
network ipp14
network ipp
network socket
network https
direct hp
network ipps
network lpd
serial serial:/dev/ttyS0?baud=115200
direct usb://TVS/MSP-250*?serial=TVS-250STAR
direct hpfax

ls -l /dev/usb/lp0

crw-rw---- 1 root lp 180, 0 Jul  1 15:52 /dev/usb/lp0

lsmod | grep usb

usblp                  20480  0
usbhid                 49152  0
hid                   118784  2 hid_generic,usbhid

1 Answer 1



Connect the printer using USB and try parallel connection via uri


Do not connect any other printers to the same device. Follow the wiki-ubuntu link for more instructions.

What I did :

Printer was connected to the computer using a USB cable. So, I had ignored parallel:/ and was focusing on usb: . Also the default URI showed on printers application was something similar.


After 6 hours, just before giving up I thought to give a try for something found From


Set up the printer with the device URI parallel:/dev/usb/lp0, either by selecting "Enter URI"...

and it worked when URI changed to,


See, the printer has two interfaces.

Centronics IEEE-P1284A Parallel, USB

I was using USB type B to USB type A connection leaving parallel port open, even though it worked for the trouble shooting section under USB -> Parallel adapter section from the above url.

  • The same could not be successfully replicated on Ubuntu 16.04 LTS with TVS MSP 250*. For sure this printer behaves differently when connected through parallel port and through usb port. Dec 9, 2020 at 15:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.