8

Yesterday my Virtualbox guests were still running. Today I get the following error for all guests (windows or Linux).

Failed to open a session for the virtual machine win10.

The VM session was closed before any attempt to power it on.

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
Interface: ISession {7844aa05-b02e-4cdd-a04f-ade4a762e6b7}

I already tried to run sudo /sbin/vboxconfig, reinstalling from Software Manager, reinstalling following Cannot run virtual machines after upgrading virtualbox from 5.0 to 5.1 and upgrading to 5.2.12 r122591 and 5.2.14 r123301. The result was always the same.

My current kernel version is 4.15.0-24-generic #26-Ubuntu SMP.

$ VBoxManage list extpacks
Extension Packs: 1
Pack no. 0:   Oracle VM VirtualBox Extension Pack
Version:      5.2.14
Revision:     123301
Edition:      
Description:  USB 2.0 and USB 3.0 Host Controller, Host Webcam, VirtualBox RDP, PXE ROM, Disk Encryption, NVMe.
VRDE Module:  VBoxVRDP
Usable:       true 
  • 1
    Looks like you need to (re-)install Guest Additions correctly. – David Foerster Jul 8 '18 at 19:57
  • 1
    @DavidFoerster To install the guest additions I would need a running guest system which I don't have. – muclux Jul 8 '18 at 20:09
  • Sorry, I meant the Virtualbox Extension Pack. That's what the answers to the linked question say anyway. ;-] – David Foerster Jul 8 '18 at 20:13
  • ok, I got the extension pack 5.2.14 from virtualbox.org and opened it (as suggested) with VirtualBox. How can I verify now that it is really installed - because the guest still don't start? – muclux Jul 8 '18 at 20:17
  • The VirtualBox management interface should show you. How or from where did you install VirtualBox btw? And what's the output of dkms status? – David Foerster Jul 8 '18 at 20:21
8

I had similar issue on xubuntu 18.04 where my Virtualbox guests was to run windows 7. Although I had Virtualbox 5.2 installed previously that worked.

  1. I made sure that virtualbox-dkms was installed by running this command:

    dpkg -l | grep virtualbox-dkms
    
  2. Then I purged it and and reinstalled only dkms:

    apt-get purge virtualbox-dkms && sudo apt-get install dkms
    
  3. Then I ran the suggested command to rebuild the kernel:

    sudo /sbin/vboxconfig 
    

This is what worked for me.

| improve this answer | |
  • Step 1 solved this error message for me on ubu 18.04 – DMrFrost Aug 15 '19 at 9:17
  • @DMrFrost: that's impossible because dpkg -l doesn't install or uninstall anything. Anyway, I ran all three steps successfully, but I keep getting the same error. – Dan Dascalescu Oct 15 '19 at 8:13
  • This worked for me on U19.10. Thanks – Junaid Qadir Jan 31 at 14:55
  • simply running 'sudo /sbin/vboxconfig' prior to launching the virtualbox worked for me – cloudcell Apr 27 at 1:36
1

After a long, friendly and fruitful chat with @DavidFoerster, it turned out that Microsoft and its weird update policy was the culprit!

David patiently guided me through the reinstallation of the VirtualBox packages from the Ubuntu repositories and check out the configuration (dkms, extension packages, etc.). At last, he asked me to try a new installation with a live ISO. It was then that I noticed that my "Default Machine Folder" defined in VirtualBox - File - Preferences - General was not usable. I knew that it was on a mounted NTFS used by the dualboot Win10 system. A closer look showed that at present it was mounted read-only, which prevented the virtual machines from starting (with a not very helpful error message).

As I recalled then, shortly after I had last successfully booted the VirtualBox guests, I had not only got Ubuntu updates, but I had also booted for the first time since long my native Win10 system. Apparently, Microsoft had then installed updates AND had reactivated the 'fast startup' option (which certainly had been deactivated before!) - so that later, back in Ubuntu, the NTFS file system was mounted in read-only mode, as Windows had not properly shut down.

Now that I have again deactivated the 'fast startup' option in Windows10, my guest systems are running again.

Thank you, David, for asking the right question which set me on the right track!

| improve this answer | |
  • I get the same cryptic error on an Ubuntu host (no dual boot or anything), and the VM directory is a regular read-write one. – Dan Dascalescu Oct 15 '19 at 8:15
0

I have encountered the mentioned issue and I tried all the suggested solutions, but they didn't solve my problem.

In my case, I figured out that the VirtualBox.xml file (which is located under ~/.config/VirtualBox) seems to be empty and there was a file named as VirtualBox.xml-prev. So I moved second file, renamed as VirtualBox.xml in the same directory and my problem is solved.

| improve this answer | |
-1

Just had the same issue and figured out the problem and an easier solution... The problem was the usb settings... if you switched your usb settings back to 1.1 it would boot again... incase anyone else like me finds this post having the same problem... that solved it for me... but thanks for this post it led me to that solution...

| improve this answer | |
  • USB was already set to 1.1 and I keep getting that useless error. Also, you may want to review your excessive usage of ellipses. – Dan Dascalescu Oct 15 '19 at 8:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.