18

Yesterday my Virtualbox guests were still running. Today I get the following error for all guests (windows or Linux).

Failed to open a session for the virtual machine win10.

The VM session was closed before any attempt to power it on.

Result Code: NS_ERROR_FAILURE (0x80004005)
Component: SessionMachine
Interface: ISession {7844aa05-b02e-4cdd-a04f-ade4a762e6b7}

I already tried to run sudo /sbin/vboxconfig, reinstalling from Software Manager, reinstalling following Cannot run virtual machines after upgrading virtualbox from 5.0 to 5.1 and upgrading to 5.2.12 r122591 and 5.2.14 r123301. The result was always the same.

My current kernel version is 4.15.0-24-generic #26-Ubuntu SMP.

$ VBoxManage list extpacks
Extension Packs: 1
Pack no. 0:   Oracle VM VirtualBox Extension Pack
Version:      5.2.14
Revision:     123301
Edition:      
Description:  USB 2.0 and USB 3.0 Host Controller, Host Webcam, VirtualBox RDP, PXE ROM, Disk Encryption, NVMe.
VRDE Module:  VBoxVRDP
Usable:       true 
10
  • 1
    Looks like you need to (re-)install Guest Additions correctly. Jul 8, 2018 at 19:57
  • 1
    @DavidFoerster To install the guest additions I would need a running guest system which I don't have.
    – muclux
    Jul 8, 2018 at 20:09
  • 1
    Sorry, I meant the Virtualbox Extension Pack. That's what the answers to the linked question say anyway. ;-] Jul 8, 2018 at 20:13
  • ok, I got the extension pack 5.2.14 from virtualbox.org and opened it (as suggested) with VirtualBox. How can I verify now that it is really installed - because the guest still don't start?
    – muclux
    Jul 8, 2018 at 20:17
  • The VirtualBox management interface should show you. How or from where did you install VirtualBox btw? And what's the output of dkms status? Jul 8, 2018 at 20:21

11 Answers 11

12

I had similar issue on xubuntu 18.04 where my Virtualbox guests was to run windows 7. Although I had Virtualbox 5.2 installed previously that worked.

  1. I made sure that virtualbox-dkms was installed by running this command:

    dpkg -l | grep virtualbox-dkms
    
  2. Then I purged it and and reinstalled only dkms:

    apt-get purge virtualbox-dkms && sudo apt-get install dkms
    
  3. Then I ran the suggested command to rebuild the kernel:

    sudo /sbin/vboxconfig 
    

This is what worked for me.

5
  • Step 1 solved this error message for me on ubu 18.04
    – DMrFrost
    Aug 15, 2019 at 9:17
  • 1
    @DMrFrost: that's impossible because dpkg -l doesn't install or uninstall anything. Anyway, I ran all three steps successfully, but I keep getting the same error. Oct 15, 2019 at 8:13
  • This worked for me on U19.10. Thanks Jan 31, 2020 at 14:55
  • simply running 'sudo /sbin/vboxconfig' prior to launching the virtualbox worked for me
    – cloudcell
    Apr 27, 2020 at 1:36
  • This helped also for Xubuntu-20-focal with VirtualBox 16.1.16
    – rundekugel
    Dec 13, 2020 at 16:57
11

Changing USB from 3.0 to 1.1 immediately fixed my inability to boot my Win10 guest under Ubuntu. Simple, easy solution.

1
  • You saved all my Windows VMs. Thanks! :-)
    – Fer B.
    Sep 29 at 9:15
8

Just had the same issue and figured out the problem and an easier solution... The problem was the usb settings... if you switched your usb settings back to 1.1 it would boot again... incase anyone else like me finds this post having the same problem... that solved it for me... but thanks for this post it led me to that solution...

1
  • USB was already set to 1.1 and I keep getting that useless error. Also, you may want to review your excessive usage of ellipses. Oct 15, 2019 at 8:17
3

The Answers given here, by the other AskUbuntu users, are already very good.
As an additional measure it might help if you download a suitable VirtualBox Extension Pack from the Downlads Page of the Virtualbox Web site.
Do this only if you know that you had the Extension Pack installed previously. (I think it enables a better USB access to VirtualBox guests).
The minor version number (for v6.1.18, thats the 6.1) of the Extension Pack should match the Minor version of your virtualbox installation.
I had an older Windows guest that refused to start because I had built a new host kernel, a new SSD to store, pending Windows upgrades, and tried to start a snapshot (I don't remember).
However a more decriptive error message ("Extension Pack too old"), better thanNS_ERROR_FAILURE (0x80004005) came up only after doing a start of a "cleaner", different Windows guest.

Maybe this is purely cosmetic, but worth a try.

2

After a long, friendly and fruitful chat with @DavidFoerster, it turned out that Microsoft and its weird update policy was the culprit!

David patiently guided me through the reinstallation of the VirtualBox packages from the Ubuntu repositories and check out the configuration (dkms, extension packages, etc.). At last, he asked me to try a new installation with a live ISO. It was then that I noticed that my "Default Machine Folder" defined in VirtualBox - File - Preferences - General was not usable. I knew that it was on a mounted NTFS used by the dualboot Win10 system. A closer look showed that at present it was mounted read-only, which prevented the virtual machines from starting (with a not very helpful error message).

As I recalled then, shortly after I had last successfully booted the VirtualBox guests, I had not only got Ubuntu updates, but I had also booted for the first time since long my native Win10 system. Apparently, Microsoft had then installed updates AND had reactivated the 'fast startup' option (which certainly had been deactivated before!) - so that later, back in Ubuntu, the NTFS file system was mounted in read-only mode, as Windows had not properly shut down.

Now that I have again deactivated the 'fast startup' option in Windows10, my guest systems are running again.

Thank you, David, for asking the right question which set me on the right track!

2
  • 1
    I get the same cryptic error on an Ubuntu host (no dual boot or anything), and the VM directory is a regular read-write one. Oct 15, 2019 at 8:15
  • Definatley not the right answer here.
    – 9_Dave_9
    Jun 11, 2020 at 22:53
2

I have encountered the mentioned issue and I tried all the suggested solutions, but they didn't solve my problem.

In my case, I figured out that the VirtualBox.xml file (which is located under ~/.config/VirtualBox) seems to be empty and there was a file named as VirtualBox.xml-prev. So I moved second file, renamed as VirtualBox.xml in the same directory and my problem is solved.

1
  • worked like a charm - do you know why this is the case though.. what created the back up "prev" file?
    – 9_Dave_9
    Jun 11, 2020 at 22:55
2

For me the issue was that I tried starting it with simply vboxmanage startvm ExampleVM but I didn't have X forwarding working, so it would presumably try to create a display and fail. Adding --type headless fixed the issue:

vboxmanage startvm ExampleVM --type headless

Of course, this only applies if headless is what you want to do.

I cross-posted this answer from a very similar question (same error code) at https://unix.stackexchange.com/a/641243/30731

1
  • I just had a similar? issue, I use VB on a different machine using X11 forwarding. I had accidentally logged out from the shell on the remote machine leaving only the graphical programs connected.
    – Oskar Skog
    Aug 29 at 10:36
0

Below commands Fixed for me (Ubuntu 18.04)

Reinstall the virtualbox-dkms

sudo apt install virtualbox-dkms

Restart the virualbox

0

After a freeze of Linux I had to do a "hard" restart of my Laptop. After reboot none of my VirtualBoxes was able to be started. I got the same error message with every Box: ns_error_failure 0x80004005.

Solution: Another regular restart of Linux
Sounds too simple, but it worked.

0

I had the same issue today and the cause was that the network adapter the VM was using until yesterday doesn't exist anymore on my host (Mint 20) for some reason.

My error message was

"Nonexistent host networking interface, name 'enp4s0' (VERR_INTERNAL_ERROR)."

I went into the VM's network properties, changed the network adapter from Bridged to something else and then back to Bridged. For whatever reason, the network interface is now enp6s0.

0

I had same issue. The Answers given here, by the other AskUbuntu users, are very important and I have followed most of them. In my case I also had the following issue: I was using an incorrect version of VirtualBox Extension Pack. For instance, If you are using a VirtualBox version 6.1.36, you also should use a VirtualBox Extension Pack of 6.1.36 version. In other words, pay attention if you are using compatible versions of VirtualBox and VirtualBox extensions. Hope it helps.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.