my wifi drops after some time and requires reboot to work again ( Centrino Wireless-N 1030 [Rainbow Peak])

similar question was posted by me for 14.04

intel centrino wireless n 1030 wireless drop after reboot Ubuntu 14.04

sudo lshw -C network gives


       description: Ethernet interface
       product: RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:05:00.0
       logical name: enp5s0
       version: 06
       serial: 24:b6:fd:27:e1:b8
       size: 10Mbit/s
       capacity: 1Gbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 driverversion=2.3LK-NAPI duplex=half firmware=rtl_nic/rtl8168e-2.fw latency=0 link=no multicast=yes port=MII speed=10Mbit/s
       resources: irq:30 ioport:e000(size=256) memory:f1104000-f1104fff memory:f1100000-f1103fff 

       description: Wireless interface
       product: Centrino Wireless-N 1030 [Rainbow Peak]

       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:09:00.0
       logical name: wlp9s0
       version: 34
       serial: 4c:eb:42:32:c2:2e
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=4.13.0-45-generic firmware= ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:34 memory:f7e00000-f7e01fff

have edited the /etc/modpobe.d/iwlwifi.conf to add the line

options iwlwifi 11n_disable=1 iwlwifi bt_coex_active=0

didnt work

have checked /lib/firmware for the file iwlwifi-6000g2b-6

it exists .( this was from https://www.intel.in/content/www/in/en/support/articles/000005511/network-and-i-o/wireless-networking.html)

dmesg | grep iwl gives

[   14.721093] iwlwifi: unknown parameter 'iwlwifi' ignored
[   14.974997] iwlwifi 0000:09:00.0: loaded firmware version op_mode iwldvm
[   14.998377] iwlwifi 0000:09:00.0: CONFIG_IWLWIFI_DEBUG disabled
[   14.998380] iwlwifi 0000:09:00.0: CONFIG_IWLWIFI_DEBUGFS enabled
[   14.998382] iwlwifi 0000:09:00.0: CONFIG_IWLWIFI_DEVICE_TRACING enabled
[   14.998385] iwlwifi 0000:09:00.0: Detected Intel(R) Centrino(R) Wireless-N 1030 BGN, REV=0xB0
[   15.035360] ieee80211 phy0: Selected rate control algorithm 'iwl-agn-rs'
[   16.149840] iwlwifi 0000:09:00.0 wlp9s0: renamed from wlan0
[   22.513003] iwlwifi 0000:09:00.0: Radio type=0x2-0x2-0x1
[   22.615238] iwlwifi 0000:09:00.0: Radio type=0x2-0x2-0x1

sudo iwconfig gives

lo        no wireless extensions.

wlp9s0    IEEE 802.11  ESSID:"HTC Portable Hotspot 4AEF"  
          Mode:Managed  Frequency:2.412 GHz  Access Point: 80:7A:BF:B9:8F:D5   
          Bit Rate=54 Mb/s   Tx-Power=15 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality=70/70  Signal level=-38 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:120   Missed beacon:0

power management is disabled

sudo iwlist scan | egrep -i 'ssid|cipher' gives (refer)

Wifi keeps dropping on Dell XPS13 running Ubuntu 16.04, not sure how to use sudoedit on file

enp5s0    Interface doesn't support scanning.

lo        Interface doesn't support scanning.

                    ESSID:"HTC Portable Hotspot 4AEF"
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP
                    ESSID:"Nokia 8"
                        Group Cipher : CCMP
                        Pairwise Ciphers (1) : CCMP

sudo service network-manager restart doesnt work

shows this after I try reconnecting

enter image description here

requires reboot required after drop

also tried the following

16.04 LTS wifi connection issues with Realtek adapter

have replaced the adapters name . since it is RTL8111/8168/8411 and adding "/" with conf file cretes problems I chose a name with out "/"

wifi drops after few hours again

I have posted the output while wifi was connected have edited this question multiple times to add all the relevant things i did but issue still persists

my kernel version is 4.15.0-24-generic

please help

edit 2: update to kernel version 4.15.0-29-generic #31~16.04.1-Ubuntu SMP doesn't solve the issue

edit 3 : have set the region to IN issue persistent

edit 4 : installed wicd-client from help.ubuntu.com/community/WICD . disconnection continues and so switched back to network manager again issue is persistent

edit 5 : took a backup and installed Windows 7 for one day , wifi worked fine implying hardware is working fine

edit6 : contacted dell support in case to be sure to know if the card was ok .they ran diagnostic and assured hard ware is working fine

edit 7 : after all the efforts , I realized that there is something missing with respect to the linux kernel itself, and so i intalled r8168-dkms via synaptic packet manager and the wifi is up since 235 minutes but again the next day drop after 30 minutes of use

edit 8 : of all the above things that I have tried edit : 7 is the most stable, how ever I am not sure of the solution as disconnection persists

edit 9 : blacklisted r8169 by following in /etc/modprobe.d/r8168-dkms.conf

# if the aliases above do not work, uncomment the following line
# to blacklist the whole r8169 module
#blacklist r8169

by uncommenting as advised to

# if the aliases above do not work, uncomment the following line
# to blacklist the whole r8169 module
blacklist r8169

disconnection persists

edit 10 r8168 in edit 9 is for ethernet and not for wifi , from the link https://ubuntuforums.org/showthread.php?t=2391119

I did as advised, though for 18.04 but since the kernel version was same , I gave a try , didnt work !

edit 11 : as requested in the comment /etc/NetworkManager/NetworkManager.conf has



edit 12 : becoming root and performing

echo -e "[device]\nwifi.scan-rand-mac-address=0" >> /etc/NetworkManager/NetworkManager.conf && systemctl restart network-manager 

doesnt help

edit 13 : now the system fails to recognize the wifi adapter

edit 14 : running the following

dpkg-reconfigure linux-firmware
modprobe -r iwlwifi ; modprobe iwlwifi

doesn't help

edit 15 : changed the line from options iwlwifi 11n_disable=1 iwlwifi bt_coex_active=0 to

options iwlwifi 11n_disable=1 swcrypto=1` bt_coex_active=0 

in /etc/modprobe.d/iwlwifi.config
does not help.

  • A couple years ago I found r8168 a little buggy and hard to retrofit and r8169 in the end did everything. Perpahs in /etc/modprobe.d/iwlwifi.conf just set options iwlwifi 11n_disable=1 and leave the rest out. As per this answer from the esteemed Chili555: ubuntuforums.org/… Today with Kernel 4.15.0-29 I had problems suspending and using 4.13.0-36 works. This in Ubuntu 16.04.5 LTS. Aug 16 '18 at 3:54
  • Please show me your "networkmanager" config file (/etc/NetworkManager/NetworkManager.conf) Aug 17 '18 at 14:26
  • Perform the following commands as 'root' (You can't modify anything): echo -e "[device]\nwifi.scan-rand-mac-address=0" >> /etc/NetworkManager/NetworkManager.conf && systemctl restart network-manager Aug 17 '18 at 14:35
  • @starkus it shows file doesnt exists.
    – sassy.geek
    Aug 19 '18 at 11:12
  • @MarcosSilveira check edit 14
    – sassy.geek
    Aug 19 '18 at 11:14

Further hardware testing

Your 1-day test in Win7 may be inconclusive. The Windows 7 driver may "drive" the wireless card differently than the Linux driver. If the Windows driver doesn't stress the wireless card in the same way, you may not see the wireless card drop off as quickly. If testing the card from Windows, I'd running it a couple days. A better test would be using an older version of Ubuntu that you have used in the past without trouble.

Don't trust the Dell diagnostic either. If their diagnostic passed, that just means that the card was functioning when they ran the diagnostic. If an electrical component on the card is malfunctioning, it may work fine after a reboot, like my friend's did, but only for a time. I had a friend that was experiencing similar issues on a Windows laptop (and using an Ubuntu LiveUSB on the same machine). My friend's card would pass diagnostic tests too because they could only be run after a reboot when the card was working. I replaced my friend's wireless card, and all of his problems went away.

From what I can tell online, it looks like your wireless card provides WiFi and Bluetooth. If the Bluetooth also stops working at the same time as the WiFi, it's more than likely that your wireless card is faulty.

Here are some things you can try for the purpose of troubleshooting:
Ignore the options you've already tried. I've only included them for the sake of anyone else who might stumble upon this post looking for answers.

  • Download an old version of Ubuntu that you know the WiFi had no issues with (12.04?) and see if your WiFi drops while running the LiveOS. If it does, your wireless card is most likely faulty and needs to be replaced.
  • Clone your existing system. Then blow everything away with a Windows install and see if you experience the same issues in Windows. If you do, it's time to replace the internal WiFi card. Restore the cloned image.
  • If you have a spare hard drive lying around, pull the one in your computer, and install the spare. Then install Windows and see if issue persists. If it does, it's time to replace the internal WiFi card.
  • Don't test anything. Just open your computer and yank the wireless card. Buy a replacement with the same model number. They're usually pretty cheap. I paid less than $10 (in China) for my friend's replacement. Drop it in. If the problem goes away, then the old card was obviously faulty. If it persists, then you're out the price of the card.
  • Finally, whether the internal card is faulty or it's a hardware incompatibility problem, you should be able to buy a USB WiFi dongle and use that. Most are compatible with Linux these days. Unfortunately, most low-profile USB WiFi dongles have weaker reception than your internal card and won't come with Bluetooth which your internal card may or may not provide.
  • i will try downgrading and let you know.. however just to add the internet has never dropped on a bluetooth internet tethering from mobile .. but wifi always have .. there were similar issues when intalled 12.04 and 14.04 but were rectified by first step of editing the iwlwifi.conf file so to my knowledge the herdware is fine for sure and with respect to wifi dongle , i could not find any that would support kernel version > 4.13
    – sassy.geek
    Aug 16 '18 at 15:45
  • Yeah, that sounds an awful lot like compatibility issues and less like hardware. As for WiFi dongles, I am on kernel 4.15.0-29-generic. I had a TP-Link TL-WN725N 2.0 lying around, so I plugged it in for kicks, and it works beautifully. In fact, I disconnected my internal card, checked ip addr just to confirm that I am only using the dongle, and I used it to post this comment.
    – b_laoshi
    Aug 18 '18 at 12:35
  • i called the dell engineer to pay a visit for service , he came , opened the laptopp, cleaned upa abit by removing almost all the chips i cant tell , but surely the wifi card was removed and cleaned as well and to my surprise , the wifi started working ! i have accepted : futher hardware testing as the most suitable answer for me !
    – sassy.geek
    Aug 21 '18 at 14:48

Reset WiFi

Your WiFi is left in an unstable state when it reboots.

Here is a script to reset / power off and on all devices. You can first reboot and run the script from the command line using sudo reset-usb. If that fixes the problem you can have it run automatically during reboot.

Add this script to /usr/local/bin/reset-usb:


# NAME: /usr/local/bin/reset-usb
# DATE: August 17, 2018.
# DESC: Written for Ask Ubuntu Question:
#       https://askubuntu.com/questions/1061754
#       Reboots / resets all USB devices including mouse & WiFi

if [[ $(id -u) != 0 ]]; then # root powers needed to call this script
    echo $0 must be called with sudo powers
    exit 1

for i in /sys/bus/pci/drivers/[uoex]hci_hcd/*:*; do
  [ -e "$i" ] || continue
  echo "${i##*/}" > "${i%/*}/unbind"
  echo "${i##*/}" > "${i%/*}/bind"

systemctl restart NetworkManager.service

exit 0

Mark the file as executable with:

sudo chmod +x /usr/local/bin/reset-usb

Edit the file /etc/rc.local and insert these lines before the last line that says exit 0:

# Reboot / reset all USB devices
  • it didnt work.. the system now likely fails to identify the adapter , cant see wifi networks at all even after reboot have undone the changes and again tried.. however i cant calim that the harware is working perfectly fine as per the another answer to the same question : further hardware testing. the bluetooth is working perfectly fine
    – sassy.geek
    Aug 19 '18 at 6:43
  • For me running the script disconnect the WiFi and bubble message appears. Then reconnects WiFi, attaches to Network and second bubble message appears. Do you get any bubble messages at all? Aug 19 '18 at 14:14
  • yes . it disconnected and then showed wireless disconnected. requires multiple reboot to identify the wifi networks. disconnection persists
    – sassy.geek
    Aug 20 '18 at 11:52
  • Have you tried to get rtl8169 driver working? For my old laptop that worked better than compiling rtl8168 on the newer kernels. Aug 20 '18 at 13:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.