In the regular Unity 3D, I used Compiz Config Manager where I could configure the Unity Plug-in to autohide the Launcher and not to show it when moving mouse to the left side of the screen. So it was perfect for using Docky.

But in Unity 2D the Unity Plug-in settings doesn't have any effect. How can I completely hide the Launcher and just have it shown when pressing the windows-key?

With the following:

dconf write /com/canonical/unity-2d/launcher/hide-mode 1
dconf write /com/canonical/unity-2d/launcher/use-strut false

it still opens the Launcher when moving mouse to the left side of the screen. I'm using Ubuntu 11.10.


2 Answers 2


There is a tool named Unity 2D Settings made by Krytarik Raido for configuring Unity 2D. It wasn't working under Ubuntu 11.10; however, he updated the tool and now works under Ubuntu 11.10.

Install it through terminal:

sudo add-apt-repository ppa:krytarik/tuxgarage
sudo apt-get update
sudo apt-get install unity-2d-settings

Run this when you are logged in via Unity 2D.

Source: OMG! Ubuntu!

  • Link no longer works - can you update your answer or provide a new link? Mar 24, 2012 at 2:53
  • The answer is updated. You can install it now :) Mar 25, 2012 at 21:04

For Ubuntu 12.04 there is an easy solution.

To make the launcher not appearing, you just have to rightclick on the Desktop and, klick background-preferences and there the 2nd tab.

enter code here

Here you have to check autohide and move the sensitivity to the very very left.

Then you have a full-screen experience like here:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .