0

Ubuntu says that OpenShot is not installed. It clearly is, as you can see in this screenshot. I've tried a number of variants, including apt remove openshot*, OpenShot, and so on. All the info I can find says this should have worked. I'd like to remove it because it is unstable on my system.

Commands such as sudo apt-get purge --auto-remove openshot return "openshot is not installed" As you can see it is installed and running. enter image description here

[EDIT] Here is the output of apt-cache:

lawrence@DianneFosseyT5500:~$ apt-cache search openshot*
gpsshogi - Shogi playing program based on OpenShogiLib
gpsshogi-data - data files for gpsshogi
gpsshogi-dbg - Shogi playing program based on OpenShogiLib
libosl-dev - library for Shogi playing programs
libosl-doc - library for Shogi playing programs
libosl1v5 - library for Shogi playing programs
libosl1v5-dbg - library for Shogi playing programs
openshot-doc - Help manual for OpenShot Video Editor
libopenshot-audio5 - Audio library used by OpenShot
libopenshot-audio-dev - Development files for libopenshot-audio
libopenshot12 - Library for creating and editing videos
libopenshot-dev - Development files for libopenshot
python-libopenshot - Python bindings for libopenshot
openshot-qt - Create and edit videos and movies.
openshot - Create and edit videos and movies.
lawrence@DianneFosseyT5500:~$ 

[Edit] sudo apt list --installed does not produce any output that lists anything like openshot.

Attempting to install openshot again results in this:

The following packages have unmet dependencies:

openshot : Depends: melt but it is not going to be installed Depends: python-mlt but it is not going to be installed E: Unable to correct problems, you have held broken packages.

12
  • Did you installed via a snap? What does snap put out (use the command snap list )? – abu_bua Jun 30 '18 at 17:20
  • I don't see it listed in snaps: ~$ snap list Name Version Rev Tracking Developer Notes arduino-mhall119 1.6.10 3 stable mhall119 - core 16-2.33 4830 stable canonical core libreoffice 6.0.4.2 65 stable canonical - – Invention1 Jun 30 '18 at 17:23
  • I did something with flatpack the other day, but I don't think it was a flatpack either, if that is relevant. Flatpack is no longer on my system. – Invention1 Jun 30 '18 at 17:24
  • Did you try sudo apt remove openshot-qt ? – abu_bua Jun 30 '18 at 17:38
  • Just tried that again. Still says it is not installed. Also dpkg -l | grep openshot* produces no output. – Invention1 Jun 30 '18 at 17:40
2

This worked perfectly for me:

sudo apt-get remove --autoremove openshot-qt

I think it's just a syntax problem you're having.

0

These symptoms result from some seriously broken dependencies. Basically, apt doesn't know about the program in question on this broken system. Any fix using apt just isn't gonna get you anywhere. The big-hammer fix will be to do a fresh install of 18.04 LTS, which happily just dropped, instead of doing a release upgrade. Fortunately I've set my system up so this will be pretty easy with little risk of losing the files, which are also backed up several ways. Thanks for your help folks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.