1

Using Ubuntu 18.04 and GNOME Shell 3.28.1.

Every time I start my computer, I have to

  • enable a certain non-system extension I'd like to use, and
  • I have to disable Night Light.

Some system extensions have always been reactivated after a reboot, despite the fact I disabled them. I had to remove them from /usr/share/gnome-shell/extensions.

Night Light is always set up with some really strange schedulde. If I correct it, it will be resetted after an undefined amount of time.

I'm guessing some configuration file is broken or has the wrong access rights. But I can't figure out which one.

8
  • regarding the "Night Light", Can you check with dconf tool? or command line gsettings set org.gnome.settings-daemon.plugins.color night-light-enabled false i.stack.imgur.com/k3jCC.png
    – UnKNOWn
    Jun 30 '18 at 9:31
  • The thing is that Night light might be on depending on the current time. For example right now, the schedule is set from 5:00 to 17:00 (it is 11:40 here). Disabling it keeps it off until I restart.
    – yoshegg
    Jun 30 '18 at 9:41
  • have you tried above command? ok just to manipulate can you adjust your night light to "manual" and set only 1minute. i.stack.imgur.com/lJjRW.png
    – UnKNOWn
    Jun 30 '18 at 9:49
  • Yes I did, but what should I see? It was already off. I did what you want, what should I look after now?
    – yoshegg
    Jun 30 '18 at 9:59
  • I set it to 12:00-12:01, now at 12:03 it resetted to 6:00-18:00
    – yoshegg
    Jun 30 '18 at 10:03
4

I got it working by removing some settings folders and just configuring everything from scratch. I found some valuable information in this answer: https://askubuntu.com/a/558450/548635

What I finally did is:

mv ~/.config/dconf ~/.config/dconf.old
mv ~/.gnome ~/.gnome.old
mv ~/.gconf ~/.gconf.old

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.