1

I'm trying to set up the High Precision AD/DA Board from Waveform. The last step is to run sudo ./dac8532_test, where it notes in the instructions that if command not found, to run chmod +x. The command was not found, so I ran chmod +x dac8532_test and tried sudo ./dac8532_test again.

The command was again not found (sudo: ./dac8532_test: command not found). I checked and the file dac8532_test is indeed in the directory I'm in (there are two other files with that name, but they have the extensions .c and .o if that matters).

What am I doing wrong? (Note: if there's any information I need to add, please let me know; I wasn't sure what was necessary.)

Output of file dac8532_test:

dac8532_test: ELF 32-bit LSB executable, ARM, EABI5 version 1 (SYSV), dynamically linked, interpreter /lib/ld-linux-armhf.so.3, for GNU/Linux 3.2.0, BuildID[sha1]=ff54034576038bbed2b96bce738f008281aa7d28, not stripped

Output of ls -al dac8532_test:

-rw-r--r-- 1 pi pi 59232 Jun 29 11:07 dac8532_test

marked as duplicate by steeldriver command-line Jun 29 '18 at 19:09

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • Is dac8532_test a binary or script? If it is a script, check that the commands the script uses actually exist. – Bernard Wei Jun 29 '18 at 18:24
  • @BernardWei I'm pretty sure it's a binary. (I used nano to look at it and it is just a bunch of special characters, nothing readable at all.) – heather Jun 29 '18 at 18:29
  • when you do a "ls -la dac8532_test", do you see execution flag set for the file? If not, try doing the chmod with sudo, like "sudo chmod a+rx dac8532_test" and try running it again. – Bernard Wei Jun 29 '18 at 18:34
  • 1
    What type of storage / filesystem is the file on? if it is on external media, it's possible that the filesystem doesn't support the *nix style execute bit – steeldriver Jun 29 '18 at 18:52
  • 1
    @steeldriver there we go, it's working now. Thank you! If you write that up as an answer, I'll accept it. – heather Jun 29 '18 at 18:55