0

I'm on Ubuntu 16.04. I use google-chrome as my default browser. It works great when I open it from the terminal with google-chrome or google-chrome-stable. It also works great when I run my test server in pycharm and click the link - opens right up.

However, when I click on any link from the terminal, it opens up chrome in a different window (even if I already have it open) and gives me two tabs.

The first one's address is http://extension%3D/tmp/.org.chromium.Chromium.KmLkmq/internal and it says This site can't be reached. extension%3D’s server IP address could not be found.

The second one's address is data:, and it's just a blank page.

Both of them have the little bar at the top that says "Chrome is being controlled by automated test software."

This happened a little while ago and I believe it was while I was using selenium and chromedriver to open and read data from some webpages, mostly just tinkering around. I'm guessing something got stuck and now it's gonna do that forever. I've tried a few things since then, but nothing seems to work.

If I change the default browser to firefox, it still opens up these weird two pages.

Should I just try reinstalling chrome or does anyone have any other solutions?

Here's a screenshot

0

I fixed it! Just uninstalled and reinstalled google-chrome-stable.

rm ~/.config/google-chrome
sudo apt purge google-chrome-stable

Then I removed everything else chrome-related (cache, chromedriver, etc).

Then I followed this answer to reinstall the latest version of google-chrome-stable. Works great now! When I click a link from the terminal, it opens right up in chrome without the weird tabs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.