17

I've got an second hand notebook at work with low specs and installed Ubuntu 18.04. The GPU is very old and every effect makes the whole system lag. Is ther any way to reduce UI effects to improve performance?

2

3 Answers 3

16

A reasonable improvement you can make is disabling animations, and this can be done without a tool, directly from the command line:

gsettings set org.gnome.desktop.interface enable-animations false

To reverse this, just:

gsettings set org.gnome.desktop.interface enable-animations true

This can also be toggled from gnome-tweaks, referenced in the accepted answer.

2
  • 1
    Thanks! Turning off animations on my MacBook 2008 White running Ubuntu 20.04 speeds it up significantly! It's now a very usable system despite being a 12 yr.-old laptop that was abandoned and no longer supported by Apple 8 yrs ago or so. Aug 9, 2020 at 19:39
  • I've also linked to your answer in my answer here: askubuntu.com/questions/663440/…. Aug 10, 2020 at 19:55
15

I've found out that there's a Tweaks tool and in the Appearance tab is an option where you can turn off animations. Just that made the computer breathe again.

You can install Tweaks using:

sudo apt install gnome-tweaks
4
  • This is not a valid solution. What's the purpose of having a high end computer that can run games but cannot render simple UI animations? There should be a solution where people can enable the animations and have no graphic issues at all. Jul 23, 2018 at 20:12
  • 2
    Its not a high end computer and I'm not using games on. The tweak tool worked just fine.
    – Balbinator
    Jul 25, 2018 at 1:51
  • 1
    Massive improvement on my XPS 13 9380 as well. Thanks! Don't forget to mark this answer as accepted. Oct 18, 2019 at 14:42
  • 4
    sudo apt install gnome-tweaks to install it. Oct 23, 2019 at 8:31
2

Although going manually through the gnome-tweaks tools and the dconf-editor works, the gsettings commands as in the other answers did not work for me, in a programmatic/CLI approach on Ubuntu 20.04 Focal Fossa.

What did work for setting this up beforehand on VMs in the cloud with XRDP was:

dconf write /org/gnome/desktop/interface/enable-animations false

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.