0

I have followed this link https://ubuntu-mate.community/t/cm-storm-keyboard-and-mouse-solved/9816 .

I used this command sudo xmodmap -e 'add mod3 = Scroll_Lock'

but it's showing me following msg xmodmap: unable to open display 'desktop:0'.

when I use xset led 3. it's not turning on backlit.

Can anyone tell me what's going on ?

0

I was breaking my head trying to solve this one, this is what I did:

sudo su
echo 3 > /sys/class/leds/input5::scrolllock/brightness

I created an script that toggles the on and off as a sudoer:

#!/bin/sh

TOGGLE=$HOME/.toggle

if [ ! -e $TOGGLE ]; then
    touch $TOGGLE
    echo 3 > /sys/class/leds/input5::scrolllock/brightness
else
    rm $TOGGLE
    echo 0 > /sys/class/leds/input5::scrolllock/brightness
fi

Still no luck trying to bind it to the scroll lock key...

0

I created a script "keyboardLedOn.sh" with:

#! /bin/sh
xset -led 2 led on
gsettings set org.gnome.desktop.a11y.keyboard mousekeys-enable true
gsettings set org.gnome.desktop.a11y.keyboard mousekeys-enable false 

Then in the end of my .profile file (~/.profile) put:

/path/to/script/keyboardLedOn.sh

I hope someone can help to improve, I know it's not a good answer, but it works

  • it's not working for me – random_user Jul 28 '18 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.