5

It runs remotely in version 14.04 but not in version 18.04. All graphics applications (gnome-todo, firefox etc) are lunched remotely via SSH. However, when I run gnome-terminal remotely via SSH, it run in non-remote native gnome-desktop.

9
  • Please show the command you're using.. Normally it is ssh -Y sysname to get an X11-capable connection. Are you saying this is what you are using but itis not working? If so, is there any error message? – SDsolar Jun 29 '18 at 5:21
  • Yes, I use putty for ssh with enabling X11 forwarding. every apps except gnome-terminal are forwarded to remote X11 server. when I run gnome-terminal remotely via SSH, it lunched on host desktop. there is not any error message. – Donghoon Yu Jun 29 '18 at 6:06
  • This happens to me too. Maybe you need not run gnome-terminal remotely. Try to start another (and third ...) putty alongside the first one and run the command lines there. Or you can try another terminal emulator program. lxterminal and good old xterm open their windows where they should. – sudodus Jun 29 '18 at 6:24
  • I suspect it's related to this Run true multiple process instances of gnome-terminal i.e. it works if you don't have a running instance of gnome-terminal-server on the remote machine – steeldriver Jun 29 '18 at 9:42
  • @steeldriver, I can verify that gnome-terminal-server is running on my remote machine (Lubuntu 18.04 LTS). (I have not tested turning it off. Have you tested that?) – sudodus Jun 29 '18 at 11:38
3

As steeldriver said in a comment above, new gnome-terminal instance behaves like some insipid Windows or Mac program; it only sends a message to the existing, running gnome-terminal to create a new window. To run gnome-terminal on a new client PC, use the --disable-factory or --app-id option.

1
  • --disable-factory Isn't supported anymore on version 3.34.0-1 on debian. I'm also unable to find more information about --app-id within the man pages. – MrWm Nov 22 '19 at 20:34
0

This command works for me. I had to add the --display argument for Centos 7 (Newer gnome-terminal).

ssh -Y HOST bash -l -c gnome-terminal --display=${DISPLAY} < /dev/null > /dev/null  2>&1 &

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.