1

Went to Ubuntu Software installed Samba 1.2.63-0ubuntu6.

Clicked 'Launch'... nothing happens

Does not show up in 'Show Applications'

1

I had the same exact issue. To fix it I ran:

sudo system-config-samba

The very last line of the output read:

SystemError: could not open configuration file '/etc/libuser.conf': No such file or directory

I simply created the file by using:

sudo touch /etc/libuser.conf

and it worked fine.

I couldn't seem to get it to appear in the application screen, but can be run by

sudo system-config-samba

from the terminal.

  • It won't show up in the application screen because /usr/share/applicaions/system-config-samba.desktop is designed to run "gksu system-config-samba". There is no gksu in Ubuntu 18.04. system-config-samba is no longer maintained and some of it's options will actually disable the samba service ( smbd ) from running. It will eventually cease to exist I suspect: bugs.launchpad.net/ubuntu/+source/system-config-samba/+bug/… Side note: Please add a -H between sudo and system-config-samba. As in "sudo -H system-config-samba" – Morbius1 Jun 29 '18 at 11:42
  • Morbius1: Do you know, are there graphical samba configuration tools similar to and with the simplicity of system-config-samba that will work in Bionic and later? – dln949 Jul 19 '18 at 1:43
0

The previous answer will get it working but there is a way to fix it not showing up on the applications screen.

gksu is one of the dependencies of samba. gksu was removed from the Ubuntu package library in 18.04 This is the reason samba doesn't show up in the applications screen.

One way to fix this is to install the version of gksu used in Ubuntu 17.10

To do this folow these instructions (from here https://askubuntu.com/a/1030066)

  1. Add artful repositories to the system:

    cat <<EOF | sudo tee /etc/apt/sources.list.d/artful.list
    deb http://archive.ubuntu.com/ubuntu/ artful universe
    EOF
    
  2. Update package cache

    sudo apt-get update
    
  3. Install gksu package

    sudo apt-get install gksu
    
  4. Remove artful repository from system for safety

    sudo rm /etc/apt/sources.list.d/artful.list
    sudo apt-get update
    

After youv'e done this uninstall samba from the command line using:

sudo apt autoremove samba

Then install samba again from the Ubuntu software center.

It is important that you install it from the Ubuntu software center and not from the command line. It wont work if you do it from the command line. I have no idea why, it just doesn't.

Samba should now show up in the applications screen.

  • This seems quite hacky to me as you are mixing packages from two versions of Ubuntu. – Robert Klemme Dec 6 '18 at 15:56
0

For those who don't mind typing password in terminal the easiest way to replace the shortcut to samba is to edit the .desktop file. In my case on Xubuntu it's located in /usr/share/applications/ and ~/.local/share/applications/

Just edit the file system-config-samba.desktop or samba.desktop with a text editor, and replace the line

Exec=gksu system-config-samba

with

Exec=sudo system-config-samba

and the line:

Terminal=False

to

Terminal=true

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.