0

I have a Dell PowerEdge 2950 (Dual Intel Xeons @ 2.5GHz, 32GB DDR2, An old 80GB SATA3 drive [RAID controller died]) and it randomly halts while booting, I'm using Ubuntu server which seems to show more progress during startup, however the same issue happens with CentOS and Debian. I ran both CPUs at full load for 5 minutes and seen no random halting or any issues (albeit it got quite warm), as well as running an extensive memory test which was successful. The recovery mode version of the kernel does work, and it allows me to drop to a root shell etc.

Ubuntu server (16.04) loads the kernel and even starts starting services, and then just halts for no reason.

Debian dosen't even start to load services, etc. when booting just says /dev/sda is clean and halts, even lack of cursor blink.

CentOS installer don't work in general.

There are no error messages, it just does this randomly HOWEVER I was able to get into debian and ubuntu's recovery mode. The point of halting changes for every boot, also there are NO errors in console.

Link to /var/log/dpkg.log: https://pastebin.com/YUqVUp9m

Link to /var/log/lastlog: It was empty

Link to /var/log/faillog: It was empty

Link to /var/log/bootstrap.log: https://pastebin.com/CmrHf2MY

Output of dmesg: https://pastebin.com/a9rnuKg0

Output of journalctl: https://pastebin.com/7zrhmdfG

ALL OF THESE LOGS WERE RECOVERED IN RECOVERY MODE

When I refer to halt I mean a complete halt of the CPU's operations. ie. No input or output to console, serial port, etc. and even a lack of response to keyboard input such as Ctrl+Z and Ctrl+C.

Also I ran the DELL diagnostics tool (Linux version wouldn't work but the MS-DOS version did) and it reported everything was fine

  • Have you checked the hardware - cap. check etc. Halting is a sign; diagnostics won't find those flaws, so open the box up & have a look... but this is not a hardware site... – guiverc Jun 28 '18 at 23:49
  • Yes, Ive looked over the hardware, I also wrote a custom program that stressed the CPU and RAM to 100% usage as to attempt to reveal any power issues – Jeremiah Jun 28 '18 at 23:55
  • If the problem relates to disk-io circuitry; as stressing CPU & RAM doesn't use those those components the halt won't happen... Have you been able to work out the system was doing just prior to 'halt'? (maybe from systemd journal? journalctl) – guiverc Jun 29 '18 at 0:12
  • The RAID controller was bad so I removed it and put in a good ole SATA hard disk, no problems whatsoever installing ubuntu server on it and it boots into the recovery mode kernel perfectly, but ill try journalctl (in recovery mode ofc), read the updated question – Jeremiah Jun 29 '18 at 0:31
0

It started working after I took out the CMOS battery to check its voltage (2.95V, so good). I put the battery back in and messed around with the BIOS some. What exactly I did that fixed this problem, I don't know. Sorry, I can't provide a conclusive answer. I wish I could, but the problem automagically solved itself. I will attempt to break it again and then I can tell you guys a conclusive reason and hopefully help anyone else with this issue

  • Removing the battery probably reset bios settings to its default. It certainly interesting to know that bios configuration can cause these sort of startup behaviour. – Bernard Wei Jun 29 '18 at 21:06
  • That's probably what had happened, the server I was using have had a history (the previous owners gave up working on it and gave it away) of weird issues like that, so my assumption is that the CMOS was probably corrupted or broken in some way – Jeremiah Oct 9 '18 at 21:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.