I've seen a lot of questions where somebody's touchpad is recognized as a mouse, but I have the opposite problem: My mouse is behaving as if it was a tap/touch input.

I have a (18.04) desktop computer with no touchpad and no touchscreen, just a regular USB mouse and keyboard. Mouse clicks have a slight delay before they register (not really noticeable), and if I'm moving my mouse when I click, sometimes it triggers "tap-and-drag"; even though I've released the mouse button, it will drag the link/tab/thing I clicked on until I click again.

Here's my xinput list, notice I don't have a Synaptic touchpad in there:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ USB Optical Mouse                         id=12   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ Sleep Button                              id=9    [slave  keyboard (3)]
    ↳ Logitech Gaming Keyboard G610             id=10   [slave  keyboard (3)]
    ↳ Logitech Gaming Keyboard G610             id=11   [slave  keyboard (3)]

I have a feeling there's something I need to change or add in /usr/share/X11/xorg.conf.d/40-libinput.conf or even /usr/share/X11/xorg.conf.d/10-quirks.conf but my attempts so far have failed.

I tried adding these two lines in the Section blocks for both pointers and touchpads.

Option "Tapping" "off"
Option "TappingDrag" "false"

I noticed I don't have as many options in my dconf-editor under /org/gnome/desktop/peripherals/mouse as I've seen on other systems. I only have 4 items:

  • accel-profile: 'default'
  • left-handed: OFF
  • natural-scroll: OFF
  • speed: 0

I downloaded a "mouse and touchpad" config utility from a different distro and tried setting the drag-tolerance to 99999 (default 8) and that just made it so I can't select things in the terminal. It still does tap-and-drag.

How can I get my mouse to behave like a mouse?

  • I have switched from Unity to Cinnamon and bought a new mouse, so now xinput shows device id=12 as ↳ Logitech USB Laser Mouse, but this tap-and-drag problem persists. – DMack Jul 3 at 17:22
  • What's the output of synclient? Ping me @Fabby after you've edited your answer to provide the info there... – Fabby Jul 7 at 9:11
  • What is your computer make and model? – WinEunuuchs2Unix Jul 7 at 17:01
  • 2
    @DMack: Stupid question: What happens when the touchpad is turned off in system settings? – Christianus Jul 7 at 20:14
  • 1
    @Fabby synclient isn't installed, so I just get "command not found" – DMack Jul 10 at 16:20

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.