0

I use Xubuntu 16.04 and when I connect my Samsung Galaxy S5 nothing happens, neither in the phone nor in the PC. The phone charges, yes, but nothing else. It does not appear any message or option about what to do with the USB connection (only charge, MTP, etc). I have installed gMTP and nothing.

Using the same phone, the same PC, the same cable, the same USB port but booting with Windows 8 everything works ok. The phone asks what to do (only charge, MTP, etc) and the PC can access normally to the content. This makes me believe that the problem is with Ubuntu.

EDIT 1:

I have noticed that when I plug the phone into the PC (Ubuntu) the "what do you want to do with the USB connection?" notification in Android appears and after about 2 seconds it automatically disappears. So it seems as is the phone does connect for a short time before it is unmounted automatically. I have tried "watch -n 0,1 lsblk" and also "watch -n 0,1 lsusb" to see if something appears during this short time period when it is plugged but nothing.

1

Activate developer mode in android by tapping the build number about 7 times.

You find the build number under Settings>about Device

then you can find a new option in the settings called "Developer options"

Under this category you will find your usb configuration. Switch to your favourite protocol and you should be able to connect to ubuntu

| improve this answer | |
  • I have already done this before asking and nothing seemed to change. The current setup is that of this link: image.ibb.co/eaUH4o/imagen.png – user171780 Jun 28 '18 at 18:38
  • if the computer does not react, if you switch the mode around i suggest to try to use another cable as Coffee_Mug suggested – thatfatnerdfromnextdoor Jun 30 '18 at 12:32
  • I have already changed the cable many times, also the USB port. – user171780 Jun 30 '18 at 18:52
  • Yes, it shows nothing related to the phone. See my edit 1 in the question, please. – user171780 Jul 2 '18 at 11:18
0

If you are using the two pronged cable that come with the phone, try using a traditional single prong micro USB cable. I’ve had issues using the two pronged cable in the past.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.