18

I'm getting the following error from my Ubuntu server:

exim paniclog /var/log/exim4/paniclog on (my server FQDN) has non-zero size, mail system might be broken.

I found a solution on the web here. Basically, I just need erase the paniclog by entering the following code:

sudo rm /var/log/exim4/paniclog

So, I know how to get rid of the error, but I don't know how it started, and how to not let it happen again. Any explanation? Thanks in advance.

2
  • 2
    Please post the contents of paniclog, to see the specific error that exim is generating, and then we can advise on how to keep the error from happening again. Exim is just doing its job and telling you that something unexpected happened :)
    – roadmr
    Feb 17 '12 at 16:28
  • This question appears to be abandoned and unanswered, could you perhaps add more detail to your question? If this question no longer applies then you can either delete it or answer it yourself if you've solved the problem. Thanks! Mar 28 '13 at 10:56
4

I had the same issue, here is what my exim4 paniclog looked like:

$ sudo cat /var/log/exim4/paniclog

2014-02-01 21:36:51 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 22:03:33 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 22:33:19 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 22:36:33 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 23:03:51 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-01 23:14:31 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned
2014-02-02 11:09:48 socket bind() to port 25 for address 127.0.0.1 failed: Address already in use: daemon abandoned

This problem was apparently solved by deleting the paniclog file

5
  • 7
    Nope. It is not solved by deleting that file.
    – Olli
    Mar 2 '14 at 16:29
  • What does an occupied address have to do with a log file? @willbeeler check what application uses port 25
    – s3lph
    Mar 2 '14 at 16:32
  • 1
    This IS the solution if the issue was temporary and the log file messages no longer apply. Delete the log to stop getting these panic warnings. Dec 18 '15 at 6:17
  • Logs are always good
    – stephen
    Apr 8 '16 at 18:49
  • yes worked.. restart exim after deleting Jan 18 '17 at 17:03
2

The answers above are bad because you delete a log file and it's then gone for future log entries from exim. The solution is to create a logfile backup.

Most Debian based distros use logrotate for this. You can force a backup with the logrotate command. Option -f is to force it and -v is for a more verbose output.

Try (for Debian and also should work on Ubuntu).

sudo logrotate -f -v /etc/logrotate.d/exim4-paniclog
1

This blog entry seems to have an answer. Looks like it can have to do with IPv6 settings and results from a change in the way the kernel supports IPv6.

Basically, disable IPv6 for now.

3
  • 1
    Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. Mar 28 '13 at 10:54
  • 5
    And now we have the reasoning behind @KevinBowen 's comment. Your link is dead and now you're answer is meaningless without it. Please summarize and extract the relevant information from all links
    – Allison
    Aug 10 '17 at 17:33
  • My assumption at the time and still is that disabling IPv6 is a temporary solution. Disabling IPv6 shouldn't ever become a standard fix so this answer should be useless 5+ years in despite the reason it was done.
    – flickerfly
    Feb 6 '19 at 15:10
1

In my case the error was as follows:

exim paniclog on my-host has non-zero size

socket bind() to port 25 for address ::1 failed: cannot assign requested address: daemon abandoned

My solution was to remove the paniclog file and do a dpkg-reconfigure exim4-config removing ::1 from the IPs to bind to.

2
  • And how did you do this dpkg reconfigure exactly? I get : dpkg: error: need an action option, so there's more to the command.
    – Seamus
    Jan 15 '21 at 8:43
  • Thanks for trying this @Seamus It was in fact wrong, it's a whole word (dpkg-reconfigure). I've fixed the answer.
    – davidag
    Jan 30 '21 at 14:41
0

In my case, the passwd file was missing, which was causing the exim4 to panic. I added a new user, and that added the file, with the proper permissions, and the content exim expects to be there.

It seems that exim needs at least one local user, and that domain had all forwarding users. Once I added a local user with a password, the errors stopped.

Your mileage may vary.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.