2

I have installed ubuntu 18.04 on my 500gb hard drive using usb stick. no partitions done, used entire disk. Installation was successful. And, on reboot(first boot) it shows A bootable device has not been detected. But, I can boot to ubuntu 18.04 after selecting boot device(usb) from boot menu. How can I load OS without selecting hard drive from boot menu.

  1. may be MBR is stored in usb.

  2. used startup disk creator for creating bootable usb

  • 1
    Chose to load from UEFI file, same stuff it did to my system! When in uefi folder go to boot or ubuntu and pick the grub*** file! – George Udosen Jun 28 '18 at 13:52
2

You have UEFI boot enable on your device and you installed Ubuntu on legacy mode.

You need to change boot options from UEFI to Legacy. Refer your manufacturer guide to access BIOS Settings.

  • Or the opposite. For me it was the opposite. I installed in UEFI, but I had UEFI disabled in BIOS, just legacy mode was enabled in BIOS. – Mitar Aug 4 at 21:49
0

Use ubuntu-18.04.1-server-amd64.iso image available from Alternate Downloads page and use Rufus to create the USB bootable device.

I had the same issue using the ubuntu-18.04.1-live-server-amd64.iso from a USB bootable device created with Etcher. Don't know if the issue was the iso OR the tool used to create the USB Key.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.