10

Laptop: Acer Predator with Ubuntu 18.04 LTS and Windows 10 (dual boot)
Specifications: Intel® Core i7-7700HQ NVIDIA GTX 1060 OS-Type: 64-bit

Everything is working fine so far, except that I can't switch to the NVIDIA graphics card in Ubuntu. Please help me, this is the first time that I have installed a Linux distribution on my PC.
I was following the installation tutorial from this website, I can't get it to work.

I have tried to install the NVIDIA drivers from the Ubuntu repositories and from the GPU Drivers PPA.
I have read many threads and tried to follow the suggestions. But same results, nothing is working. Below is a detailed step by step of the last commands I ran in the order they were executed.

  1. Purge everything NVIDIA:

    sudo apt purge nvidia-*  
    
  2. Purge the PPA:

    sudo ppa-purge ppa:graphics-drivers/ppa    
    
  3. Autoremove:

    sudo apt autoremove
    
  4. Clean up:

    sudo apt auto-clean
    
  5. Blacklist Nouveau:

    Edited the file /etc/modprobe.d/disable-nouveau.conf and added these lines:

    blacklist nouveau
    blacklist vga16fb
    blacklist rivafb
    blacklist nvidiafb
    blacklist rivatv
    blacklist amd76_edac
    alias nouveau off
    alias lbm-nouveau off
    options nouveau modeset=0
    
  6. Re-add the PPA:

    sudo add-apt-repository ppa:graphics-drivers/ppa
    
  7. Check for recommended drivers:

    ubuntu-drivers devices
    
  8. Install the recommended driver from the PPA:

    sudo apt install nvidia-driver-396
    
  9. Reboot the system:

    sudo reboot
    
  10. Check which drivers are in use:

    $ lspci -k | grep -EA2 'VGA|3D'
    00:02.0 VGA compatible controller: Intel Corporation Device 591b (rev 04)
        Subsystem: Acer Incorporated [ALI] Device 118a
        Kernel driver in use: i915
    --
    01:00.0 VGA compatible controller: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] (rev a1)
        Subsystem: Acer Incorporated [ALI] GP106M [GeForce GTX 1060 Mobile]
        Kernel driver in use: nouveau
    
    $ lspci -nnk | grep -i vga -A3
    00:02.0 VGA compatible controller [0300]: Intel Corporation Device [8086:591b] (rev 04)
        Subsystem: Acer Incorporated [ALI] Device [1025:118a]
        Kernel driver in use: i915
        Kernel modules: i915
    --
    01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GP106M [GeForce GTX 1060 Mobile] [10de:1c20] (rev a1)
        Subsystem: Acer Incorporated [ALI] GP106M [GeForce GTX 1060 Mobile] [1025:118b]
        Kernel driver in use: nouveau
        Kernel modules: nvidiafb, nouveau, nvidia_drm, nvidia
    
    $ nvidia-smi
    NVIDIA-SMI has failed because it couldn't communicate with the NVIDIA driver.  
    Make sure that the latest NVIDIA driver is installed and running.
    
    $ nvidia-settings
     ERROR: NVIDIA driver is not loaded   
     ERROR: Unable to load info from any available system
    
0

2 Answers 2

9

You have to disable Secure Boot on your machine, boot into BIOS and disable it in the UEFI settings.
There won't be any security problem at all and the alongside installed Windows will boot nevertheless.

3
  • 1
    I understand this has been accepted as an answer but what does secure boot has to do with switching hybrid card? Aug 10, 2018 at 1:09
  • 2
    @AftabNaveed Because kernels running on UEFI Secure Boot systems will require signed kernel modules. Signing the NVIDIA Kernel Module
    – cl-netbox
    Aug 10, 2018 at 9:09
  • 3
    I'm having this issue and have secure boot disabled. Jun 15, 2019 at 4:23
-1

I just installed Ubuntu 18.04 and I have the same issue with NVIDIA GF 550Ti driver.

Running lshw -c video shows UNCLAIMED driver.

Here are the steps I followed to solve this:

  1. Disable Secure Boot.

  2. In the terminal, run the following commands:

    sudo ubuntu-drivers list 
    sudo prime-select nvidia 
    sudo apt install nvidia-driver-418-server 
    cd Downloads 
    chmod +x FILENAME.run 
    sudo ./NVIDIA-Linux-x86_64–410.57.run -- no-x-check 
    reboot
    
2
  • It is a set of random commands.
    – Pilot6
    Feb 10, 2021 at 12:45
  • Why do you down vote and not explain why it's random command lines? What is your solution?
    – Only Spam
    Sep 14 at 4:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.