0

I ran into a brick wall installing wireguard on my System running Ubuntu 18.04, ever since then i can't seem to be able to install apps. I always get a prompt >E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem

i have tried running 'sudo dpkg --configure -a' but at the end it just gets stuck. i have embedded a screenshot showing the error screenshot of error

  • Try to fully uninstall wireguard: "sudo apt-get --purge remove wireguard" if the program was installed.. – Max Jun 28 '18 at 6:41
  • i have tried the command "sudo apt-get --purge remove wireguard" but i am still getting the 'sudo dpkg --configure -a' error – martinkem Jun 28 '18 at 6:56
  • ok, unfortunately it is late for me here, I will try and solve this in the morning. – Max Jun 28 '18 at 6:56
  • Welcome martinkem to askubuntu! Don't post images if they only contain terminal output. – abu_bua Jun 28 '18 at 12:04
  • @abu_bua ok, I'd take it for next time – martinkem Jun 28 '18 at 13:45
0

I had the same problem with Wireguard on my HP Envy. I cleared /var/lib/dpkg/updates. None of the other files/directories in dpkg held anything pertinent.

Source: DPKG Problem - Ask Ubuntu

  • Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Elder Geek Jul 25 '18 at 21:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.